Clion 2022.3.2 is extremely slow.


It becomes unresponsive after 3-5 min of use.
I use Power Save Mode to improve performance it helps but not for long. 

in Activity monitor most often: 

  • <JIT compiler>
  • <infrastructure: AWT-AppKit>
  • <unidentified: UI thread>


It's consuming all my CPU even when there's not background tasks?

Is there a way to limit CPU usage? 

If there's no could you prioritize this feature? Just make some internal jobs  single threaded.  

Mean time I have to switch to VSCode :(


CLion 2022.3.2
Build #CL-223.8617.54, built on January 25, 2023
Subscription is active until September 29, 2023.
Runtime version: 17.0.5+1-b653.25 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 12.4
GC: G1 Young Generation, G1 Old Generation
Memory: 24576M
Cores: 16
Metal Rendering is ON

Non-Bundled Plugins:
    idea.plugin.protoeditor (223.8214.6)
    com.intellij.ideolog (
    dev.meanmail.plugin.nginx-intellij-plugin (2022.1.1)
    ru.adelf.idea.dotenv (2022.3)
    mobi.hsz.idea.gitignore (4.4.4)


Hi all!

>It's consuming all my CPU even when there's not background tasks?

Andrey  please capture a CPU snapshot while reproducing the issue and send it to clion-support at so that we can take a look.

Sbachmann the same request to you.


In there article you suggested, it says:  "should click on Help | Diagnostic | Start CPU Usage Profiling."
I don't have it.
Here's what I have:

Activity monitor:

I also noticed it reindexes Google tests, python venv, and other files before/after each debug run, even thought there's been no changes whatsoever.
May be you'll just add some simple timestamp checks and add sleeps in loops to yield cpu as a quick fix. otherwise CLion completely is unusable.


I realized that CPU snapshot was in a plugin. I disabled all plugins trying to alleviate the problem. 
I'll record the snapshot. 


Please sign in to leave a comment.