PyCharm 2022.3.2 (64bit) won't run on Windows 11


I installed pycharm using pycharm-community-2022.3.2-aarch64.exe but on lauching a window will pops up with "this app can't run on your pc".
Also tried launching pycharm by running the pycharm.bat file and it results a dialog box stating the java.exe within the pycharm's installation folder is valid but is for a machine type other than the current machine.

Kindly help me resolve this issue.


Sndysngh make sure that you downloaded a compatible version with your computer architecture  (for example in case you have  ARM64) -

Alternatively you may try to use JetBrains Toolbox -

Ryzen 7 has x86-64 architecture. ARM 64 (aarch64) version will not work with this processor type; this is why the x86-64 version from the Toolbox app works as expected.
I've additionally checked the download page, and by default, it suggests the x86-64 version, which you can manually change to aarch64.

I met the same problem, is there anyone resoved it?


I am experiencing the same issue when trying to load communicate edition, OS is window 11 , Intel 13th Gen Intel(R) Core(TM) i5-1345U.

is there any feedback on the issue 


Hi Sharat Achary Could you provide a bit more details about your hardware? Is it ARM64-based? 

If so, please make sure you downloaded the right build from :


I have the same issue with the latest

2023.1.1 - Windows ARM64 (exe)

I have a Windows 11 system

system type is x64-based

Installing the 32bit version worked, but I ran into issues when creating a venv:

ModuleNotFoundError: No module named 'virtualenv.activation.xonsh'

Also it feels a bit of a waste, when there is a 64bit version available.

Is there anything else I can try?


Unfortunately, I can't reproduce the problem on the Win11 arm with the 64-bit installer. 

Does PyCharm show any errors on startup? If yes, please send us a screenshot or an error log. You can also check the logs directory for possible crash reports by following this link:

Any extra information you can give me about your development environment would be beneficial.

I am getting this error on 2023.2.1 community edition.



I checked the log directory but there is no directory named JetBrains or PyCharm in Local, LocalLow or Roaming directories in AppData directory.


I have same issue, downloaded pycharm-community-2023.2.2-aarch64.exe 


Jolly Jacob 

You have an Intel CPU, but downloaded the aarch build of PyCharm. Please download the Intel build (not ARM64)


Daniil Bogdanov Thank you, it helped. Download version without ARM 64 and it's work!


Please sign in to leave a comment.