JetBrains Gateway issues on ec2 server


I have been developing a server application on my local machine using Goland and Goland has been flawless. Up until the other day, I was running my backend server on my local machine calling it from my client application also from my local machine. This has worked fine.

But now, I've moved my go server up to an ec2 server and some of the code needs to be tweaked. So I cloned my code on the ec2 server and from what I read, it seemed like I could use JetBrains Gateway to do remote work on the server. But whenever I try to log in, it always reports back "The host doesn't meet the minimal requirements, the host doesn't have enough memory to run the remote IDE backend. Minimal size 3.8 GB, total size .94. "

I reconfigured the ec2 server to be bigger and still no luck. 

I've resorted to using Visual Studio Code to remote in and it has no issues with me working with the code remotely. So I'm wondering if someone might have some advice with JetBrains Gateway? I prefer to use Goland if possible. 



What is the Gateway version you use? 


Jetway Gateway 2022.3.2. I thought it was that latest version because I just barely downloaded it from your site.


Please sign in to leave a comment.