unable to debug javascript in 2022.3.2 ultimate edition with chrome 111 on mac m1 (arm)

debug session opens chrome but never connects to debug.  Eventually get message in the debug window "waiting for connection to localhost:xxxxx"

this failure started suddenly.  worked yesterday.  machine was turned of overnight so I do not believe updates could explain.  


I have the same problem on Windows.  Worked fine this morning, then suddenly broken with the same message as you, interrupting development.

I have tried the solutions here, without success: https://intellij-support.jetbrains.com/hc/en-us/community/posts/360009567459-Webstorm-2020-2-1-Remote-Debugging-do-not-work


Chrome Dev 111.* rejects the requests unless started with --remote-allow-origins; the fix is available in WebStorm 2022.3.3 RC and 2023.1 Beta.


Hi Elena, 

I have the same problem with 2022.3.2. 

Then i installed 2023.1 Beta, also does not work. 


When I open Chrome with "open -a Google\ Chrome --args --disable-web-security", it works. 



With WebStorm 2022.3.3 the debugger connects, but no watch or expressions, see img


same problem right after update to 111 and --remote-allow-origins did not help in my case, but downgrade to 110 does.


Same as others. Windows. Was working 5pm GMT yesterday. Off overnight and not working 10am GMT

Current Chrome is 111.0.5563.65. It updated this morning, but only *after* the issue had presented.

Was using default Chrome settings, i.e. no custom User Data Directory, but changing to custom doesn't seem to have worked.

In addtion to the "Waiting for Connection" message I get a "Closed Explicitly" error immediatly after clicking, and before the Chrome window launches.

Site is running and debugging on localhost in Chrome itself, just not connecting to WebStorm debugger.
Site is Vue.js, started using `npm serve` script, then ctrl-click to debug.


Have installed 2022.3.3 RC2 and am afraid that it doesn't fix the issue for me.

There are a few improvments over the 2022.3.2

  1. No longer warns "Closed Explicitly"
  2. No longer warns that it cannot connect to the debugger 
  3. Is able to open the requested site on Localhost

However, and most importantly, it still fails to connect the debugger in Chrome to WebStorm. During the stages above the Debug tab displays a green light next to it. As soon as the page is loaded that light disappears. No expected messages appear in the Dubug > Console window, however they do display in the Chrome Debug Tools Console. 


For me the best solution was to restore a old version of Google Chrome from Time Machine and disable autoupdate for Chrome, now i can work with the current stable version of Webstorm.


Debugging works fine for me in WS-231.7864.77, IU-223.8836.35 and WS-223.8836.27 with Chrome 111.0.5563.65 (Official Build) (64-bit)
Should you still have problems after upgrading, please create a new youtrack ticket, attaching your idea.log (Help > Show Log in ...) and a video recording of the issue


Like  Nikolaus Morocutti, adding "--remote-allow-origins" to Chrome or Chromium args did not make debugging work again. And like  Nikolaus Morocutti and Andreas, once reverted to previous version of chromium (snap revision 2367, which is chromium  110.0.5481.177), debugging is working again.

(Can't upgrade to a new IDEA version since my company did not pay yet for the upgrade.)


OS X Ventura 13.2.1, M1 Max 64GB. Upgraded WebStorm to  2022.3.3 (Build #WS-223.8836.27, built on March 1, 2023 ). Did not resolve the problem with debugging in Chrome. Also added "--remote-allow-origins=*" and "--disable-web-security" but that didn't help either. When starting debug session in nx react project (Shift + Cmd +Click), Crome launches but will not load app's page (https://localhost:4200) and appears to wait for connection. As soon as debugging is off, Chrome loads page.
Before upgrade to 2022.3.3 and Chrome to 111 I never had any issues with debugging my project.

Debugging works for the same ns react project with Chrome 111 using VS Code without any problem.


i think its actually --remote-allow-origins=*


There is another issue that might break the debugging in 2022.3.3 -  WEB-59866; the fix will be included in 2022.3.4 update that is coming soon. For now, I can only suggest using 2023.1 Beta, it's not affected by this issue


Thx Nikolaus Morocutti !  With --remote-allow-origins=* (instead of --remote-allow-origins), debugging with Chrome works again with my old IDEA UE 2020.03.


Updating to 2022.3.3 fixed this issue for me on OS X Monterey Intel.


This happens to me too on Chrome as of yesterday


Same here, went to bed and now can't debug, shouldn't have gone to bed.

WebStorm 2022.3.3

Build #WS-223.8836.27, built on March 1, 2023

I have tried the 2023 EAP build and that does not work.

Mac M1 12.3.

Chrome Version 111.0.5563.64 (Official Build) (arm64)


Hi all - I'm having similar problems as of a few days ago. I'm on an intel Mac - Webstorm - trying to remote debug a Vue.js app in chrome.

Initially couldn't get the debugger to attach .. upgrading to latest Webstorm resolved the connection problem, but I'm still unable to hit debug breakpoints in the IDE. I've also tried the EAP release of Webstorm. Same issue.

EDIT:  Adding --remote-allow-origins=* to the command line options for chrome (within webstorm prefs), also doesn't seem to resolve the issue for me.



2023.1 Beta got the debugger working again for me on OSX Webstorm


Markhunter27 the option has to be specified in Settings | Tools | Web Browsers and Preview, in the Chrome Settings dialog that opens when you select Chrome configuration there and press Edit

But you don't need using this option if you have upgraded the IDE. You must be affected by the other issue, see https://intellij-support.jetbrains.com/hc/en-us/community/posts/10432962465682/comments/10496062628370 above


Upgraded to 2022.3.4. Debugging with Crome 111 still doesn't work. Tried with and without --remote-allow-origins=*, makes no difference

Crome doesn't connect to the page, waiting. As soon as the debugger session is stopped, app's page opens

M1 Max, 64GB, OS X 13.2.1


Do you have Ensure breakpoints are detected when loading scripts option enabled in your Debug configuration? It can be https://youtrack.jetbrains.com/issue/WEB-59872/Cant-attach-debugger-to-Chrome-Dev-111-in-Linux-Mint-with-Ensure-breakpoints...-enabled


when Ensure breakpoints are detected when loading scripts is enabled, page doesn't load. After I cleared this option, page loaded, debugging started to work and stops correctly at configured breakpoints. So for me the issue with debugging seems fixed after clearing this option.


2022.3.4 fixes the issue for me.

Same as above. 

If I remove 'Ensure breakpoints are detected when loading scripts' then the page will load and breakpoints work fine. 

--remote-allow-origins=* - has no positive or negative effect.


Thanks for fixing so fast,



2022.3.4 fixes the issue for me too.


Is there any official update on this issue? 


Could you clarify what issue is meant? All issues mentioned in this thread are already fixed, I'm not sure what update you are asking for


OK, here goes: 
I'm using IDEA 2022.3.3, Ultimate edition.
My chrome is Version 111.0.5563.111. 
Until now, I clicked debug, idea reconnected to the previous session. Now every time I click debug, it opens a new session. Debugging works, but it is uncomfortable.


looks related to WEB-59988; please could you check if you can reproduce the issue in a custom build provided in https://youtrack.jetbrains.com/issue/WEB-59923/Instantiating-tests...-Debugging-Angular-tests-not-possible#focus=Comments-27-7004888.0-0 ?


Please sign in to leave a comment.