Waiting for connection to localhost:50327. Please ensure that the browser was started successfully with remote debugging port opened. Port cannot be opened if Chrome having the same User Data Directory is already launched.

This is the third time I've ran into this problem, each time I've spent a few hours trying to fix only for it to resolve itself and not know why.


I've tried the following solutions:

- Deleting web-browsers.xml and other.xml:

- Checking ports aren't in the exclusion ranges:

Start Port    End Port
----------    --------
      5357        5357
     49152       49251
     50000       50059     *
     52550       52649
     59100       59100     *
     65154       65253
     65254       65353
     65354       65453

* - Administered port exclusions.

- Reinstalling Chrome / Webstorm (2021.2.4) with Windows restart

- Deleting the Chrome User Data Directory / Pointing it to my person User Data Directory

I have no idea what's wrong. I'd greatly appreciate some help in figuring out the cause of this to avoid more wasted hours the next time I run into this issue.



Chrome 111.* released last week rejects the requests unless started with --remote-allow-origins=*; the fix is available in 2023.1 Beta.
See https://youtrack.jetbrains.com/issue/WEB-59211/Cant-attach-debugger-to-Chrome-Dev-111-Invalid-handshake-response-getStatus-403-Forbidden


Thanks Elena, it worked for me. Chrome version 111.0.5563.64 


Worked for me as well. Thanks Elena!

Chrome version: 111.06563.65.

IntelliJ Version:

IntelliJ IDEA 2022.3.2 (Ultimate Edition)
Build #IU-223.8617.56, built on January 26, 2023


It works for me too. Thanks Elena.


For you WebStorm users out there, I got the fix by updating to 2022.22.5.


Please sign in to leave a comment.