Cannot run or debug java web application


I am using IntelliJ IDEA 2022.2.3 (Ultimate Edition).  This may be an EAP version which I was asked to download to try to solve another problem. 

Yesterday everything was working fine.  Today I started up intellij and tried to run my java web application as normal through the debugger.  It displayed a Chrome browser with the path name: blank. There was a message down the bottom which I highlight below.  I changed absolutely nothing since yesterday.  Please help because I can't do any work.  Here is the strange message. 

Waiting for connection to localhost: 50327.  Please ensure that the browser was started successfully with remote debugging port opened.  Port cannot be opened if Chrome having the same User Data Directory is already launched.  

There were no Chrome browsers running.  I found this problem in your IDEs Support.  It said the fix is available in 2023.1 Beta.  I clicked on this link only to find it was PhpStorm.  


Same message, same error. 


Please clarify. Are you telling me the solution for Phpstorm is the same for intellij IDEA Ultimate Edition? Is there a new version 2023.1 Beta I should download? How can both Phpstorm and Ultimate Edition have the same version? That's why I thought it wasn't applicable.


The issue seems to be related to: As it is fixed in the latest EAP release (2023.1 beta), please download it and check if your issue is resolved. 


Thanks Ivan.  I have downloaded the 2023.1 beta from your link above.  It is now working again.  Much relieved. 


Running the 2023.1 beta version today I have noticed some very high CPU usage, causing the fans on my computer to run very noisily.  Screenshot of task manager attached.


Could you provide a CPU snapshot recorded during the high CPU consumption? For instructions on how to record a snapshot, please check:
Also, please provide your IDE log files (Help > Collect Logs and Diagnostic Data). You can upload the zip file here:, and provide the uploaded file ID.


Hi Ivan

This issue with high CPU usage has not occurred again.  


Please sign in to leave a comment.