Unable to add ssh interpreter

Hi All,

How are you?

I'm trying to follow the steps provided here and set up a remote ssh interpreter.

I was able to do all the steps but then when going back to the main menu of project interpreters the new interpreter I just configured was missing. I tried to delete the .idea folder and follow the steps again, but without success. 

Just as a side note there is a remote env that works fine if I am directly working on the remote server.


System configuration:

OS: Ubuntu 18.04

Pycharm version: 2022.3.3



Please open File | New Project Setup | Settings for New Project | Python Interpreter, click on the dropdown list, scroll to the bottom and select "Show all". The full list of available interpreters should open; please check if newly created interpreters are on this list.

Alternatively, you may try deleting jdk.table.xml in the configuration directory in the options folder. This file contains all the interpreters added to the PyCharm; removing it will clear pycharm's interpreter list.


Thanks, deleting jdk.table.xml solved the issue.

I have another related question. When I'm trying to create a new ssh interpreter pycharm creates a new deployment file even if at the first step I select existing ssh connection.  The unwanted deployment file contains random mapping while in the existing file, they are configured correctly.



Those mappings are not exactly random; you can set path mapping when adding an SSH interpreter, as shown in a screenshot:


I'm sorry but this is not answering my question. even if I configure the sync folders to match the ones in the deployment mapping tab, still new deployment configuration is created with this /tmp/.... path.

Can you explain in detail what are the steps to create ssh interpreter? as I said before following the guide did not solve my problem.



Sure, here is how you can add an SSH interpreter: 

1. Go to Settings | Project | Python Interpreter.

2. Select Add interpreter | SSH.

3. Choose a new or existing connection. Enter all the required credentials or specify the SSH key.

4. Specify all the required parameters, including interpreter location and how your project folder will be synced.

5. Once everything is set, click ok, wait until synchronization and indexing finish, and the interpreter is ready to run your code.

Double-checked if there are any issues with mappings, work as expected in the latest release: 

I think there might be some misconfiguration with deployments; please check path mappings in Preferences | Build, Execution, Deployment | Deployment, select the required Deployment configuration and open the Mappings tab; if the Deployment path is set to /tmp/... dir then everything works as expected.


Please sign in to leave a comment.