Cannot type in terminal

I'm using Pycharm 2022.3.3 on Ubuntu 22.10.


The terminal doesn't allow any characters to be typed within PyCharm. I have tried scouring the Internet for a fix, but, no avail. Also the Python Packages is empty. It says "Nothing to show".

I have tried uninstalling and reinstalling as well.


Any help is appreciated.



Please open Preferences | Tools | Terminal and check what is set in Shell Path. If nothing is set, try /bin/bash, close the terminal tab if any open and re-open it. 

If that didn't help, please take some screenshots of the terminal tab and Preferences | Tools | Terminal and attach them to the thread. 

Also, how PyCharm was installed on your PC? 



I tried your methods and it didn't work.

I have attached the screenshots.

I installed it using the tarball via the website.


Oh, I see, it seems like PyCharm can't access a shell binary.

Let's check what's in the log file. Please upload idea.log (Help | Show logs in...) here and tell me the upload ID. 


Did you fix it? How? Having the same issue here


me too Having the same issue


Please sign in to leave a comment.