Nouvel utilisateur de pyCharm je viens d'installer l'application sur mon Raspberry Pi ( raspbian) . Lors de mon installation en utilisateur ayant l'ensemble des droits, je me suis rendu compte qu'il était impossible d'écrire dans la fenêtre terminal de l'application. Les autres fenêtres comme console python fonctionnent bien. 

j'ai installé PyCharm après un téléchargement du dossier "pycharm-community-2022.3.3.tar.gz" et une décompression dans le dossier opt.

J'ai aussi installé comme demandé dans les recommandations "openjdk-11-jdk"

J'utilise l'interface graphique LXDE UI (Sachant que le terminal de base de l'interface fonctionne correctement) 

Lors du lancement de PyCharm, j'ai le message suivant 

A savoir aussi le lien " suivez ces instructions" ne fonctionne pas.

Avez-vous une idée pour ce problème qui me pose la question sur le bon fonctionnement de l'application sur mon système .

Merci de votre retour 

Désolé je n'ai pas bien compris la selection des sujets j'ai mis "



Hello FrThib. Please, try to download the separate PyCharm installer for ARM64 from this page using the dropdown menu to select the corresponding option: 


If it doesn't help, please, share your IDE log with us. To obtain it, press the `Help | Collect Logs and Diagnostic Data` dropdown menu item in the IDE window. To share it with us privately, you can use the JetBrains Uploads service and post the IDE you receive here. 


Thank you Olga Mulina for your answer I have downloading the file and extract it in otp.

But unfortunately the file “pysharm.py” doesn’t run. After some research I found the following message "exec: /opt/pycharm-community-2022.3.3/jbr/bin/java: not found». I suppose it's necessary to reinstall Java in this repertory. Currently I have this java version.

I continue my research to understand the java problem



FrThib, please, note that the pre-installed JRE is not needed for PyCharm installation because our own runtime used for running IDE is included in the archive. Please, make sure that the directory and file mentioned in the error (/opt/pycharm-community-2022.3.3/jbr/bin/ and java inside) are presented in the filesystem. 


Oups, I have these directories ans java inside 

On the other hand  pycharm does always not  start, without precise information



Could you please check if the  pycharm.sh  file executes properly if you move all  pycharm-community-2022.3.3  directory to another path, for example, the user home directory?


Salut Olga Moulina

J'ai le même résultat lorsque je copie le répertoire et lance " pycharm.sh " dans le répertoire personnel de mon utilisateur. le symbole du sablier apparaît sur l'afficheur pendant une vingtaine de secondes puis plus rien...


If you run the  pycharm.sh  file from the command line, does the error keep the same? Does it help if you uninstall Java from Raspberry PI or set up  JAVA_HOME  and  PYCHARM_JDK  environment variables to the  pycharm-community-2022.3.3/jbr/bin, and try to rerun the file? Also, if there is a  idea.log  file in the IDE log directory, please, share this file with me via the JetBrains Uploads service.


hi Olga Moulina

I still have the same fault when I run "pycharm.sh" from the command line 
"./pycharm.sh: 168: exec: /home/FrThib/Téléchargements/pycharm-community-2022.3.3/jbr/bin/java: not found"

You can find the idea.log file here:
Download ID: 2023_03_30_CJo11GqCBYFvKEDieUsNYR (File: idea.log)

Indeed the problem seems to come from java.


Thank you for the provided details. Could you please also share the result of executing the  /opt/pycharm-community-2022.3.3/jbr/bin/java --version  when the archive is unpacked to the  /opt  directory? 


here the java version 


FrThib, sorry for the late reply; it's not the same command I asked for. To execute the java binary file that is located in the   /opt/pycharm-community-2022.3.3/jbr/bin/ , please execute  the ./java --version  command in this directory.
Also, please, specify which OS version is installed on your Raspberry PI? It's needed in case I'll try to reproduce it on my side. 


Hi Olga Mulina

No problem for the late reply, it is not very urgent i have other possibility for working. I would also like to thank you for your precious help.
You will find below the os version , however the command "./java --version" not running .


It looks like you are still using the wrong PyCharm version.

Please delete it and download this one instead: https://download.jetbrains.com/python/pycharm-community-2023.1-aarch64.tar.gz.

Unpack and run this version. Share the fresh idea.log if the issue persists.


Hi Serge Baranov and Olga Mulina

Currently I used the file "pycharm-community-2022.3.3-aarch64.tar.gz" extracted into pycharm site 
I want to try this new version


it's the same result with this new version "pycharm-community-2023.1-aarch64.tar.gz"


We do not provide JetBrains Runtime for armv7, only for aarch64. The JNA / PTY libraries and fsnotifier are also not available for armv7, therefore file watcher and terminal will not work correctly.

The only possible solution to get the aarch64 version working on Raspberry Pi is to install the 64-bit OS.

See https://pimylifeup.com/raspberry-pi-64-bit/.


hello Serge Baranov

My system run with aarch64


hi everybody
 I don't really understand the problem with 64 bits but i will see this on the middle of the week 


hi all 

I looked to change the OS but it seems too complicated because I have a lot of applications on my pi4 that will have to be reinstalled afterwards. It will take me a long time. I prefer to stay with the current configuration and not use pycharm for now
thank you for your help


Please sign in to leave a comment.