No longer able to run pre-push hooks, wrong shell?


Hello! For some reason, this morning when I sat down to code, I noticed that my GoLand was using a different shell whenever I pressed the shortcut to open the Console. Normally I use zsh, but for some reason it was now using /bin/sh. I was able to change this in the settings, but then I found that other things were also changed, for example now I am unable to push from GoLand and run pre-push hooks, because the IDE will fail telling me that it can't locate golangci-lint. 

make: golangci-lint: No such file or directory
make: *** [check] Error 1
error: failed to push some refs to 'ssh://'

Do I have to tell GoLand to read the .zshrc file somehow? What could I check in the settings to make sure I am able to commit and push directly from the IDE, running hooks with the configuration in my zsh profile? 


Thanks a lot!


Oh, this seems to be more an issue with my terminal set up, I see that even outside of GoLand my zsh is spitting out errors that I had not seen before, and I don't recall changing anything in the configuration in the past hours or even days 

/Users/x/.zshrc: line 18: syntax error near unexpected token `('
/Users/x/.zshrc: line 18: `source <(antibody init 2>/dev/null)'


GoLand will handle .zshrc file if you pass it to a GUI application like a pipeline, for example:

  • Start macOS terminal with zsh.
  • Launch GoLand from there (instructions).

In that case, you ensure all your variables will be passed to the IDE.


Please sign in to leave a comment.