Webstorm - When I try to use debugger got message "Debugger didn't connect during timeout"

OS: Windows 11

App: Webstorm 2023.1 (but tried in different version but have same problem)

Language: NodeJS

Library: mochaJS

A day back debugger is working. But stopped working suddenly, when I try to use debugger got message "Debugger didn't connect during timeout" and cant use breakpoints. 

I tried: install another version, remove options folder. But problem still is there.


Looks like Node.js can't connect from WSL to your Windows host
Here are the instructions on how to set up Windows to work with WSL ( you have to make sure that Protected network connections is disabled for WSL for Private, Public and Protected networks).


I tried but message doesnt change. I tried deactivate firewall completly but doesnt work.

Please could you also try the `Fix WSL Firewall settings` action (available from **Help > Find action**) as suggested in

Best regards,

Same here. It was working yesterday but stopped today. 

I have already disabled Norton and Windows Firewall completely.

Already tried to "Fix WSL Firewall" settings.

Already tried to change nameserver to host machine in WSL /etc/resolv.conf


Elena Pogorelova tried, but problem is still there.


please could you check if a workaround from WEB-59241 description helps?


Esquiroas I changed this port back to default value (63342) and it's working again.



Elena Pogorelova - I just wanted to inform Jetbrains that 5 of us at work are having this problem. IDE in Windows, using WSL2 Ubuntu. This issue appeared last week with the update PhpStorm update or windows update.


I was able to follow the workaround from WEB-59241 and it DID work. However it's not idea to have to go into C:\Program Files\JetBrains\PHPStorm and hack away on the debugConnector.js


Hopefully Jetbrains will figure out the root cause so we don't need to have all employees do this.

Please could you collect the logs per request in https://youtrack.jetbrains.com/issue/WEB-59241/NodeJSs-inspect-port-in-WSL-is-not-reachable-from-the-IDE-in-Windows#focus=Comments-27-6880891.0-0 and create a new youtrack ticket, attaching the logs and your settings (File > Manage IDE Settings > Export Settings...)?

Hi Elena Pogorelova, reading the thread that you sent, in this comment (https://youtrack.jetbrains.com/issue/WEB-59241/NodeJSs-inspect-port-in-WSL-is-not-reachable-from-the-IDE-in-Windows#focus=Comments-27-7268888.0-0) I found the solution for my problem. Just update wsl to last version:

wsl --update --pre-release

I've been getting this too, but on Mac, with Webstorm 2023.1.  It started off as an occasional thing, but now I simply can't debug with Webstorm.  Which is pretty problematic, as I kind of need a debugger.


Tools you issue must be different; please share the detailed problem description within a support ticket


I'm still getting this issue on macOS running WebStorm 2024.1


Same here, macOS with WebStorm 2024.1.4, 
having this issue for at least a year on one of my projects,
it is 100% reproducible, 
in the past restarting webstorm at least allowed me to debug once or twice before it gets stuck like this.

It's now getting ridiculous, I am unable to use Webstorm with the main project leaving me no option but moving to VSCode like all of the members of the team (this issue was the final straw for them)


Barak Edry please could you clarify what error is meant? This thread is about using Node.js on WSL, I'm not sure how it can be reproduced in Mac environment. Please share the detailed problem description within a support ticket




Please sign in to leave a comment.