Digital Ocean, managed MongoDB and datagrip


On digital ocean on my managed database it says this:

On the having difficulty connecting it takes me to how to do it with mongodb installed locally, it don't help at all.

I don't know if SSL connections are definitely required because I seem to be able to connect with Datagrip just fine using user name and password or if datagrip is somehow supporting the SSL connection somehow by default? But it does not seem so by way of the settings. 

I mean whats my best steps forward here? I am on windows 10 so ideally don't want to install mongodb locally as it always messes stuff up it seems, additionally managing SSH keys is a pain, but I can't even work out how or if DO are enforcing SSH anyway its confusing, you also have TLS compatible client there, so does that mean overall I should be fine with username and password in datagrip?

Note this ain't for a production level app or anything I am just testing an app out I am building.

I am probably way overthinking this and the fact most likely, I hope is that datagrip is fine to use, is TLS by default in some way or do I add it to the end of the string as per below? Lot of information out there , I am new to learning mongo so hopefully someone can help with this confusion...

This is what I sent to digital ocean: as per this link, I followed most of it, I am ideally, as using windows 10, trying to avoid using SSH key and installing mongoDB locally. I managed to connect fine to my MongoDB (managed) on digital ocean but its warning me to connect with SSL, I can't work out how to do this in Jetbrains DataGrip can you advise or help me find an article so I can? Am I better installing it all locally and the SSH key? Datagrip seems so much easier. Would something like this be correct? mongodb+srv:// to connect? It feels finnicky so I don't know if this is the best approach?


Hi Jamie,

In DataGrip, SSL is not enabled by default for data source connections, but you can enable it explicitly and make required via data source settings:

See also:


Thanks for the response that makes perfect sense!


Please sign in to leave a comment.