Disable automatic tests



I frequently find CLion runs out of memory when using a reasonably large project (google's 'dawn' in this case - large but not massive!). The problem got so bad I splashed out on extra memory but it keeps happening.

However, I've recently noticed that when it does happen, CLion always seems to be executing the project's tests, and never seems to stop, it seems to be stuck somewhere.The project does include a lot of tests so maybe that's it?

Anyway, aborting the tests seems to reliably solve the memory error (alas too late for a refund on my RAM) and things return to normal.

I have tried to disable automatic tests but can't work out how to do it - is it possible?


1 comment


> CLion always seems to be executing the project's tests

Do you mean unit tests? Probably CLion doesn't execute tests, but scans the project to find them.

Does this project use Google Test framework? If yes, please try setting the cidr.test.framework.base.class.iteration.count registry option (Help | Find Action..., type Registry there) to 1 and check if it helps. Or you can try disabling the corresponding unit test support plugin (File | Settings | Plugins - disable "Google Testing" plugin).


Please sign in to leave a comment.