Unable to Generate Angular 2 Structures

I can create and run a new angular-cli project in Webstorm 2016.3.2 however when selecting File > New > Angular CLI the dialog tells me that there are no matches found.

Running ng g ..... from the command line works as expected.

 

12 comments
Comment actions Permalink

Yes I am using version

angular-cli: 1.0.0-beta.24

so that looks like the issue.

 

Thanks.

0
Comment actions Permalink

Downgraded to: angular-cli@1.0.0-beta.20-4 and it works for now.

1
Comment actions Permalink

I've the same issue with angular-cli 1.0.0-beta.28.3 and Intellij 2017.2.3

I'm grateful for any advice.

0
Comment actions Permalink

Please try upgrading cli to the most recent version. IDEA 2017.2.3 doesn't support old cli versions

0
Comment actions Permalink

Thanks, it works now. I also had to set up a new project.

0
Comment actions Permalink

I just started using WS and have WebStorm-181.3007.17 EPA -- I am getting "No matches found" when File | New | Angular CLI.

My configuration: Angular CLI: 1.6.6
Node: 9.4.0
OS: win32 x64
Angular: 5.2.2

 

0
Comment actions Permalink

the problem is caused by https://github.com/angular/angular-cli/issues/9412
We'll be releasing 2017.3.4 with a workaround (loading predefined list if the cli command fails)

0
Comment actions Permalink

thanks, the eta on 3.4?

0
Comment actions Permalink

not sure.. within 2 weeks, i think

0
Comment actions Permalink

I'm running into this issue with the latest version of webstorm and 

"@angular/cli": "~6.0.8",

Any help is greatly appreciated!

0
Comment actions Permalink

What IDE version do you use? https://youtrack.jetbrains.com/issue/WEB-32557 is fixed in 2018.1.3

0

Please sign in to leave a comment.