Alt+key not working in embedded terminal

Answered

For instance, ALT+F and ALT+B works in the editor for moving the caret to start of next and previous word respectively. However, in the embedded terminal this is not working - though the chain ESC-ESC-F and ESC-ESC-B provides the same functionality I would really prefer to use the aforementioned.

Is there a way to have ALT+F and ALT+B work in the embedded terminal? Disabling mneumonics does not appear to solve the problem.

PhpStorm 2016.3.2
Ubuntu 16.04

 

35 comments
Comment actions Permalink

Thanks Erykwho, this hack worked great

0
Comment actions Permalink

I'm sorry for opening old wounds, but I ran into a similar problem after updating from PHPStorm 2021.1 to 2021.2.

I use the embedded terminal *mainly* for committing and going through directories. The latter still works, but the former gives me some trouble, as our commit message convention states that a commit message must begin with "[BUFIX|FEATURE|TASK] Tell what you did" and hitting Alt+5 on my MacBook inserts 5 spaces, which it did not before, and should not, as this is the shortcut for '['.

I tried:
- disabling overriding the IDE shortcuts
- switching to bash
Neither of those worked and the behaviour persisted.

I'm using Mac OS Catalina on a 2019 MacBook, with PHPStorm 2021.2 and zsh as terminal in the embedded terminal.

 

 

0
Comment actions Permalink

Please try disabling the "Preferences | Tools | Terminal > Use Option as Meta key" option, that should help.

Just in case:
https://youtrack.jetbrains.com/issue/IDEA-274574

1
Comment actions Permalink

Vasiliy Yur you are incredible, that solved the issue right off the bat :-)

 

(Knowing what you are looking for probably helps, thanks for sharing your knowledge!)

0
Comment actions Permalink

Fantastic, thank you for the update and have a nice forthcoming weekend!

0

Please sign in to leave a comment.