Rails Server Launcher Wasn't Found In Project

I'm using IntelliJ IDEA 2016.3.2 and attempting to setup a rails run/debug configuration.  When attempting to set it up, I get an error saying that the rails server launcher wasn't found in the project.  I've opened the directory as my root project directory where a subdirectory called bin has a rails file.  I'm able to run the rails server from that same directory without any problems.  I've tried deleting my .idea folder and reopening the same folder and I get similar results.

I am using rbenv with ruby version 2.3.1.

17 comments
Comment actions Permalink

Hello Aaron,

could you please specify if the corresponding facet (Ruby on Rails) is configured and module SDK is set (screenshots from File | Project Structure | Project Settings | Modules/Facets would be great)

0
Comment actions Permalink

Same for me with 2017.2 EAP and before with 2017.1.3 EAP. I also have bin/rails and can start from the command line. This bug occurs every few versions. I also don't have any module SDK settings apart from those for the Ruby SDK. Project Structure doesn't have a submenu called Project Settings and the term facet can't be found at all via the settings search. See the attached screenshot on how my Project Structure dialog looks. As one can see there are Rails engines/submodules (api/backend/core). But this doesn't stop bin/rails from working on the command line. Also I could use this repo via Rubymine in Rubymine 2016.2.

0
Comment actions Permalink

By the way, there's at least this other post https://intellij-support.jetbrains.com/hc/en-us/community/posts/206060689-Rails-server-launcher-wasn-t-found-in-project

And another thing, what's more effective in reaching personnel at JetBrains? That YouTrack issue tracker or this community site?

Here's a ticket on that tracker that shows a user for whom an update from 2016.3.1 EAP to 2016.3.2 EAP fixed the launcher problem. Updating seems to help and also this can be considered an ongoing issue. Since I have it with 2017.2 again. Added that to the comments of said issue.

0
Comment actions Permalink

Hi,

I'm having the similar issue with RubyMine 2017.1.4 (build 171.4694.21). I'm using a remoteruby sdk with ruby 2.3.1 and rails 5.1.2.

Not sure if it makes any difference but since its not possible to create a rails project when you only have a remote sdk, the project was manually created using the rails new command.

My goal will also be to setup a debug rails configuration.

 

Thanks,

Miguel

0
Comment actions Permalink

I encountered this error this morning using the latest IntelliJ Ultimate. It took me the whole day to solve it, not something you'd expect when you're a low income earner paying for premium software licence. I really wish there was a call center. It's really disappointing that there's such a lack of walk-through setup guides on even this kind of basic setup stuff.

I decided to post the solution on Stackoverflow with lots of explanatory screenshots and I hope this solves a lot of people's issues: 

https://stackoverflow.com/questions/30141740/rubymine-rails-server-launcher-wasnt-found-in-the-project/44922746#44922746
0
Comment actions Permalink

I just encountered this error again. I thought upgrading to the latest version of IntelliJ Ultimate 2017.2.4 would help, but upgrading made things worse, instead of it migrating all my previous configuration settings, plugins, and SDKs such as Ruby on Rails as was requested, it just broke everything. I wish Jetbrains support was more accessible.

 

 

0
Comment actions Permalink

@Luke,

sorry for the inconvenience. Could you please specify what exactly has been broken. You can also write me to rubymine-support@jetbrains.com.  

1
Comment actions Permalink

Hi, I had the same problem, I have created the project again and save the default configuration of the servers on project.

I tested with rails application and rails api and now it's working.

0
Comment actions Permalink

RubyMine 2021.2 RC
Build #RM-212.4746.79, built on July 23, 2021
Runtime version: 11.0.11+9-b1504.13 x86_64
macOS 11.3.1

Its 2021, and I've been having this problem for a couple of months. (and I've tried the suggestions for deleting the .idea folder, but it made no difference).

The full message from run/debug configuration is

Run Configuration Error: Rails server launcher '/private/var/www/cs2020/script/server' was not found in a project

And this is true.  There is no such script. But I am able to run the rails server using 'rails server', so if I could configure this launcher string I could probably move ahead.

Can I configure the launcher script?
Can I add something appropriate to the script directory? (There is no 'server' script in 'bin' either).

It seems as though this should be easier to fix than it appears... but I've thought that before and been wrong.

Thanks,

Anita Graham

p.s. Just realized that the path referenced in the error is wrong too, as I have recently changed my project structure. But even if it were right, there is still no script called 'server'.  (Path should be '/private/var/www/cs2020/site/script/server')

0
Comment actions Permalink

Anita,

In this case it might be worth recreating the binstub (via 'bundle binstubs rails').

But if you don't want to add the binstub back, you can create your own Run Configuration (Gem command one), which is just a terminal command for 'rails server'

0
Comment actions Permalink

I have the same problem since this morning, I can't work anymore :(

I didn't ask for any update and yet I see: Build #RM-221.5080.196, built on April 11, 2022

Does RubyMine updates by itself ??

This is very frustrating

0
Comment actions Permalink

Franz, could you please specify what kind of installation did you use? Is it snap by chance? As for the issue, since you've also submitted an issue in our support system, we'll work on it there. 

0
Comment actions Permalink

I don't remember, it was several years ago, how can I check ?

0
Comment actions Permalink

You can check if there's any output for 

snap find rubymine

command in Terminal

0
Comment actions Permalink

The answer is yes

11:23:59 $ snap find rubymine
Name      Version  Publisher   Notes    Summary
rubymine  2022.1   jetbrains✓  classic  The Most Intelligent Ruby and Rails IDE

0
Comment actions Permalink

Please tell me how I can disable auto updating of RubyMine to avoid further breaking RubyMine regarding my Rails 3 app ?

Or at least get some warning/info about what's going to break next time ?

0
Comment actions Permalink

That's how snap works, please refer to their documentation:

https://snapcraft.io/docs/keeping-snaps-up-to-date

But you can check the following thread with different workarounds: https://askubuntu.com/questions/930593/how-to-disable-autorefresh-in-snap

0

Please sign in to leave a comment.