Pycharm debugger not working

Answered

Hi pycharm community,

I have been using pycharm with its debugger for a while whithout problems, but now without any reason that I can think of the debugger stopped working...

That is the output I see on console when trying to debug any script:

 

C:\Python34\python.exe "C:\Program Files (x86)\JetBrains\PyCharm Community Edition 2016.3.2\helpers\pydev\pydevd.py" --multiproc --qt-support --client 127.0.0.1 --port 52680 --file C:/Python34/PycharmProjects/AnalizeMultipleLogs/main.py
pydev debugger: process 7400 is connecting

Connected to pydev debugger (build 163.10154.50)

Process finished with exit code 1

 

I have tried the following with no success:

 + upgrade pycharm saving the existing config

 + upgrade pycharm deleting existing config

 + delete existing pycharm and install it again from scratch.

 

Any hint will be welcomed!

6 comments
Comment actions Permalink

Hmm, this looks like an existing ticket. It mentions the --multiproc option, which is also in your startup.

Can you try setting (globally) the PYCHARM_DEBUG=True variable and then commenting in the ticket?

0
Comment actions Permalink

I am having the very same problem with Pycharm 2016.3.2 under Windows 10.

The problem persists unchanged after globally setting PYCHARM_DEBUG=True

The problem disappears when opening a different project and trying to debug the same program from within that project.

0
Comment actions Permalink

This happened to me because I clicked on the breakpoint caused by an exception icon (red circle with a lightning bolt on it) which apparently disables those kinds of breakpoints, it puts a green circle inside the red circle to let you know you did something.

If you go to View Breakpoints (two big red circles next to two little circles on the debug panel; or ctrl+shft+F8) you can re-enable them there. The Suspend option for Any Exception needs to be ticked for the debugger to function as you want.

2
Comment actions Permalink

I had the problem as Franxvarela, and ended up in this forum while searching for an answer.

For me, the following worked:

In the debugging view at the bottom, I selected the 'view breakpoints' button (with the two red spots on it, ctr+shift+f8)

In the Breakpoints dialog I selected each breakpoint in my code (which may have very old breakpoints still stored!) and hit 'del' to remove each breakpoint (so not disable, but removing them)

I noticed that some breakpoints were shown to be past the end of current code version/update, so perhaps that is the explanation of the problem?

3
Comment actions Permalink

Solved for my after disabling coverage from pytests.

0
Comment actions Permalink

How to disable coverage from pytest? Woud you please send pictures?

0

Please sign in to leave a comment.