WebStorm 2016.3.2 Node.js debugging does not work!

I'm debugging locally on a simple Node/Express app, which was also created in this same version of WS, today.

I've built and debugged Node apps several times in WS so I'm familiar. Never had a problem before.

I set breakpoints and nothing happens. It's not working at all. No errors. It's as if it's not debugging at all. I Googled and found several StackOverflow posts about it. I can't find anything to suggest I'm doing it wrong.

I went to Run -> View Breakpoints and they're all listed. All are "Enabled" and "Suspend" is checked.

At a standstill without debugging. Any ideas?

9 comments

I met same issue! I can debug node.js application anymore!

1

are you using Node 7.x? It's a known issue unfortunately, see https://youtrack.jetbrains.com/issue/WEB-24629. Hidden option for turning dev tools protocol support off (js.debugger.node.use.inspect=false) will be included in next 2016.3 update - see https://youtrack.jetbrains.com/issue/WEB-24629#comment=27-1809582.

For now the only workaround is downgrading Node.js to 6.x:( Full Node 7 support (using v8 inspector) will be available in 2017.1

0

Ah...My node version is 7.x

 

Thanks @Elena

0

Yes, using latest: 7.4.0. That's unfortunate that it's broken. Don't have the option of downgrading Node without doing a lot of changes in my production env. now, so will use VS Code until WebStorm is fixed.

Thanks.

0

I choose an easy way, downgrade Webstorm.

1

That would be great, lolo - where can I find a copy of 2016.3.1? The most recent prior version I can find is 2016.2.4 here...but I'd hate to go back that far:

https://confluence.jetbrains.com/display/WI/Previous+WebStorm+Releases

Wish this issue was fixed. It's putting a damper on me professionally, now.

Thanks again.

0

what version do you need - Windows, macOS, Linux?

0

@Vincent  I just down grade to 2016.2.x.  Happy to see other one share a 2016.3.1 download link. :)

0

Please sign in to leave a comment.