Support for Apple TouchBar


Hello guys,

is there any plan to support new mac touchbar? It would be nice to have debug capabilities or other stuff on it :).

Is there any ETA to it?


Official comment

We do plan to support it, please follow for updates.

And half a year later there still seems to be no progress whatsoever on this issue.


Are there any updates?

Upvote if you want a touchbar support as well?


Still waiting on this.


Really desirable function.. I hope it's coming soon..


This isn't coming is it?


Still work in progress.


Hi y'all, just thought I'd post a workaround for now. You can enable permanent function keys on MacOS for IntelliJ through System Preferences.

Go to System Preferences > Keyboard > Function Keys > click + > IntelliJ IDEA

Now your TouchBar will behave in a way actually useful for us engineers. Happy shortcut debugging!


Use BetterTouchTool to add any buttons you want to the Touch Bar. Pretty easy once you get the idea behind the tool. And a great way to get way more out of your Magic Trackpad or Mouse.

Here are some instructions to setup BTTm, including samples for PyCharm. If you want to find your own icons that match the IDE, use the Finder to "Show Package Contents" for your JetBrains app, e.g. /Applications/, and then go to Contents/lib inside the application. You should see a file called icons.jar - unarchive that and you should all the icons used somewhere or other in the IDE. Here's my current setup, though I will enhance it as I use the IDEs more in-depth. Enjoy.


The standard solution (System Preferences > Keyboard > Function Keys > click + > IntelliJ IDEA) doesn't seem to work for me. I'm using Toolbox, and the applications are installed in "/Users/<username>/Library/Application Support/JetBrains/Toolbox/apps/..." but even if I navigate to there and select the app(s) I am using the Mac doesn't show the function keys!

The fact that it hasn't been fixed in a year is a terrible indictment on Jetbrains' ability to support the Mac platform.



@S Mcphee1, I had a similar issue as yours on my new Macbook pro touchbar, and the solution is the extra step once you're on the Keyboard page:


Go to System Preferences > Keyboard > Shortcuts > Function Keys > click + > IntelliJ IDEA


@S Mcpheel. If you right click on the icon in the dock and say show in finder you will find the actual executable you need to add in the shortcut prefs.

In my case the path was this...  "/Users/jeff/Library/Application Support/JetBrains/Toolbox/apps/Rider/ch-0/173.3994.1125/Rider 2017.3"


Hope this helps.




I have found that because I was using the Jetbrains Toolbox, the application was installed in a different location as indicated by Jeff. 

The apps themselves though should still have native Touch Bar functionality built into them.


Hi guys,

We know this is "work in progress" but any update on how it will look like or when it will be available?

MacBook Pro came out more than year ago.


I made a simple Touch Bar plugin that you might be interested in

It's pretty basic, but maybe you'll find it useful.



@Erbot James - I absolutely love your plugin.

Can you make it configurable through simple text or json file so we can add our own buttons?


@Erbot James is it supposed to work with WebStorm, or only IntelliJ? Seems active and restarted WebStorm, but no change.


hi, i'm make a plugin, for support touch bar, sorry for my english. 


I am also making a plugin lol.

You can find it in intellij's plugins also


My plugin has customisation support


I've figured out how to add intellij to the listed apps that use the function keys with the touchbar model mac (when intellij is installed via toolbox)


ok so,

>> launch Activity Monitor

>> find the process that is IntelliJ IDEA

>> run "Sample Process"

one of the diagnostic data it gives you is the path of the memory queried by the running process

>> look at "Path:"

for me it was "Path: /Users/<$USERNAME>/Library/Application Support/JetBrains/Toolbox/apps/IDEA-U/ch-0/<$RELEASE_VERSION>/IntelliJ"


in order to view hidden files while in the finder window that the setting app opens for you (the only way to find the file that is the actual app - because /Users/<$USERNAME>/Library is a hidden folder) i had to press 

COMMAND + SHIFT + ">" (i guess it's also the "." key)

I don't know if that works for everyone,

but it also happens to be my custom made shortcut to open a Terminal window so maybe that has something to with it.



Please sign in to leave a comment.