Version control log tab suddenly empty, although all git commands still work through ide


In the version control the tab 'log' is suddenly empty (has always worked before)

all other git commands, for example show history still work

Restart of IDE and invalidate caches and restart did not work

There are no exceptions in the intellij log file

IntelliJ IDEA 2016.2.5
Build #IU-162.2228.15

Official comment

Here is the corresponding request in the tracker:

The issue was that the log area has been resized to 0 widths, SOlution -

Please submit a ticket to support, and attach full IDEA.log to troubleshoot.


I have just experienced the samme issue on 2017.2.5 on Mac (#IU-172.4343.14). It is only the Log view that seems affected, I was able to pull, fetch, commit and push without issues. But the Log was empty no matter if I tried filtering it or not.

I could get the Git Log working again by going into Preferences->Version control and remove the configured folders - click Ok and then using the VCS menu enable version control again - select Git, and now the Git Log view works again.


Update: Thanks for the link to the tracker Dmitriy - apparently then the issues are not quite the same. My git log view had the proper width and I could see and click on all the buttons buttons. 


Please sign in to leave a comment.