Annoying Search Everywhere popup

Hello,

every time when I copy-to-clipboard anything, then I return to PHPStorm, Search Everywhere popups in the main editor.

It doesn't matter from where I've just copied something, Search Everywhere is there when I return to the IDE.

How can I fix this?

 

Thank you.

9 comments

Hi there,

Default shortcut for Search Everywhere is pressing Shift 2 times.

1) If you change that (assign any other shortcut) in "Settings/Preferences | Keymap" (just search for "everywhere" to quickly locate that particular action) -- will it prevent that popup from automatically appearing?

2) Will it work OK if you use another GUI theme?

0

Hi Andriy, thank you for your answer,

I've already did that: changing the shortcut in the Settings.

And I use a customized version of Dracula, customized by me. But it doesn't matter which theme I use.

For instance, if I'm working on Word, I select and copy a fragment of a text, then switch back to PHPStorm, the Search Everywhere popup appears.

I'm using the latest version of PS:

PhpStorm 2016.3.2
Build #PS-163.10504.2, built on December 20, 2016

JRE: 1.8.0_112-b15 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation

on a Windows 7 x64 machine.

0

>And I use a customized version of Dracula, customized by me. But it doesn't matter which theme I use.

1) It's Darcula not Dracula :)

2) You must be talking about Color Schema (Settings | Editor | Colors & Fonts) because actual GUI Theme (Settings | Appearance & Behavior | Appearance) is different thing and cannot be customised by user (unless digging/hacking into distribution files)

So.. try changing GUI Theme to Windows (for example) and see how it will behave there

Please also change keymap to Default (Settings | Keymap) and see if it will make any difference (just for testing)

 

>For instance, if I'm working on Word, I select and copy a fragment of a text, then switch back to PHPStorm, the Search Everywhere popup appears.

That's very odd behaviour. Never faced anything like that myself and have not heard about it from others.

Can you please try with all 3rd party (not bundled by default) plugins disabled. Any difference?

Do you have any keyboard-related software installed (e.g. something like Automatic keyboard layout switcher etc)?

Try also closing all other running apps (ideally -- all -- Skype, Antivirus etc)  -- to see if they may introduce such behaviour

 

>JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation

1) Could you please try launching PhpStorm using 32-bit launcher -- it should run using JetBrains own JDK (comes bundled with PhpStorm installation -- it has some important fixes that affect other aspects -- maybe it will also help in your case)

2) If you need to run 64-bit Java -- please try 2017.1 (currently at EAP stage) -- it comes with 64-bit own JDK bundled

0

Same thing.

My guest is that PS detect the clipboard and automatically offer to search everywhere.

0

When I copy the text inside the cell (the MD5 string), then switch back to PS, the Search Everywhere menu appears.

0

Hello, I am experiencing this same annoying problem, on a Windows 8 64bit OS.

I'm guessing it has something to do with being on windows, since Ceci is experiencing the same problem I am (the gif she uploaded shows it exactly).

I installed PHP storm yesterday (10-03-2017 || 2017-10-03) so it's with the most current version of PhpStorm  for windows.

I use Alt + Tab to switch between windows (e.g. between PhpStorm & MySQL Workbench, or a browser window etc... ).
As I've tried to re-created it to provide more specifics on how to make it happen I am seeing that it's not very consistent... as I'm working, however it typically comes up every time. There could be an element of needing to be out of PhpStorm for an amount of time before the problem will occur.

Additionally it seems like doing something in another program for a few minutes (if this is time related or not I don't know) could be involved in causing the problem.

Hope this is helpful in re-creating the problem in a windows environment.

UPDATE: I just found that being in another program/window then clicking on the top bar of the PhpStorm window seems to bring the search everywhere up more frequently.
(NOTE: it still comes up when I alt+tab to the window but not as consistently as clicking)

0

I did a quick search on Issue Tracker .. but could not find any tickets that matches your description (possibly I have missed it). Right now I have no idea what might be triggering such behaviour.

Usually there is an issue with this popup that it disappears quickly or in the middle of typing (Linux specific issue -- seem to be doing OK on Windows).

I suggest to submit a ticket at Issue Tracker so corresponding devs will have a look at it.

0

@Mattrummler

Maybe it has to do something with regional keyboard layout - are you using English keyboard or another one?

Or is there any 3rd-party software for working with clipboard?

0

Hey guys.
Finally a solution, at least on Windows platforms.

The solution is here:

https://youtrack.jetbrains.com/issue/IDEA-161094#comment=27-2518218

and here:

https://stackoverflow.com/questions/20542053/how-do-i-disable-the-search-everywhere-shortcut/48894157#48894157

Worked for me on Version 2018.1.1

I Hope this helps :)

0

Please sign in to leave a comment.