GIT unable to remember my password

When using the Git Fetch button I am asked for my password.

I type this in and tick "Remember".

The next time I load PHPStorm I have to add my password again.


I was also unable to install the update from 2016.3.1 -> 2016.3.2. I had to uninstall and reinstall fresh, which I assume is part of the same issue.

Running windows 10 Pro 64bit

17 comments

Hello,

What is the policy in File | Settings | Appearance & Behavior | System Settings | Passwords?

0

Hi Vladimir,

 

The setting is "In KeePass" and the location is:

C:\Users\<name>\.PhpStorm2016.3\config\c.kdbx

The file is there and is 2KB in size with a modified date of last year.


(Note - tried adding a master password to see if that helped. It changed the modified date to now, but still did not fix the issue)

0

Hello, 

I have the same issue.

I am using - macOS 10.12.2

0

We have an issue, when a remote URL contains a username, Git passwords cannot be saved: https://youtrack.jetbrains.com/issue/IDEA-162522
Please vote and follow.

1

Same here since a recent update. Was OK a few weeks ago.

 

Linux Ubuntu latest PHPStorm as of this post date

1

Weird, I just unticked the Remember box when pushing and typed the password in hoping that next push it'd ask again and reticking it would cause it to remember.

It didn't ask again...

Now it seems to push without asking.

2

Same issue still, PhpStorm doesn't remember password for GitHub and Database-connection regardless of checked 'remember' box

0

Are you on linux? Are you using the "In KeePass" option at File | Settings | Appearance & Behavior | System Settings | Passwords?

0

I'm on Mac (macOs 10.13.6), using native Keychain

0

Done. It worked. Is native Keychain broken? Can we expect it to be fixed any time soon?

0

Should work. Can't find any confirmed bugs with native Keychain.

You can try to revert back to keychain, reproduce the issue & upload somewhere your idea.log file (Help > Show log in...) for us to look into.

 

0

Yessir. Here's the log: https://drive.google.com/file/d/11MV-GpqCveIhOTgezEU2Z9K9d7fWD8mm/view?usp=sharing. Reproduced by setting the password setting to native Keychain, git-pulling twice. Thanks for your help

0

The error you're getting is "The user name or passphrase you entered is not correct". There was a couple of users facing the same errors when accessing Keychain.

A workaround that worked for them was locking and then unlocking the logins group in Keychain.

0

This seems to have worked, thank you!

0

Had the same error - switched to KeePass and it works now.

The issue persisted on 2017.1 and 2018.2 and behaved the same.

I think it might be something to do with Linux permissions, but hadn't had time to test it.

Anyhow, KeePass works :)

 

0

Please sign in to leave a comment.