2016.3.3 upgrade disaster


Yesterday, I upgraded from 2016.2.5 to 2016.3.3 and have been regretting it ever since.  As soon as I upgraded, the Java editor was no longer able to resolve my imports on my Maven projects--even those in the same project and same module!  I managed to work around this by removing the .idea directory and all the .iml files from the project and re-importing it.

Now, I seem to have lost all of the error highlighting in the editor.  Find Usage on methods has now become unreliable in that I select the getUpdater() method in one of my classes and ask to find its usage, IntelliJ reports "No usages found in Projects and Libraries".  However, if I click on the folder containing the class and select Find In Path and search for the "getUpdater()" text, I find the 22 occurrences in the two other classes in the same package.

I guess I am going to have to downgrade because this is a disaster for my productivity...



Please try File | Invalidate Caches | Invalidate and Restart.

Check idea.log for errors (https://intellij-support.jetbrains.com/hc/articles/207241085).


I tried invalidating the cache and that didn;t do anything for my problem.  There were some errors in the log but after shutting down, deleting the old log, and restarting, I see no errors yet my problems still exist.

It looks like Importing Maven projects is broken.

1.) For my project (which is complex but was easily handled by earlier versions of IntelliJ), while it recognized that it was a Maven project during import, none of the directories were marked (e.g., <module>/src/main/java was not marked as a Sources Root, <module>/target was not excluded, <module>/src/test/java was not marked as a Test Sources root, etc.).

2.) The dependencies in the POM are not being resolved.  After marking all the directories within the project, those are being resolved but none of the external dependencies declared in the POMs are being resolved (by IntelliJ, that is...Maven has no problem building the project).



Try changing the Maven version and JVM used for importing.


I was using the internal versions included with IntelliJ.  I have switched them to the ones that Maven uses when I run from the command-line (same versions as the bundled ones...by the way).  However, I am reluctant to re-import since it took me a long time to mark the folders in the project and I don't want to have to go through that exercise again, should this change not fix the issue.


Please sign in to leave a comment.