Turn off 100% of all code auto-formatting everywhere forever under every circumstance

Answered

I know many of you find auto-complete of various stripes helpful, but I am odd and would like to disable all automatic functions that involve inserting or deleting text without me directly requesting that specific character be inserted or deleted by virtue of an explicit keystroke under any and all circumstances.  Is there a way to achieve this?

42 comments
Comment actions Permalink

Hi Serge, thank you for the reply.

My only suspects would be the Eclipse Code Formatter plugin and Other Settings>Save Actions.

Thank you for the hint! I will explore this venue...

0
Comment actions Permalink

I still seem to be unable to persuade IntelliJ to please stop autoindenting my constructors, parameter lists and multiline strings.  How can this be accomplished?

0
Comment actions Permalink

IntelliJ's auto completion is completely out of control. It seems every time I use it, there is new stuff it does that I don't want. Most recently, its adding an extra asterisk in markdown files when I type one. I just want to create a bullet point, not italicize. All this unnecessary "smartness" is just getting in the way of being productive at this point. Please stop trying to be smart unless you can actually deliver. Please have a good comprehensive way to configure these things so you can only enable what you want and not have to constantly deal with an ever changing set of autocomplete BS.

0
Comment actions Permalink

Fresheneesz I can't reproduce that. Try EAP version of IntelliJ IDEA

Check that there are no markdown-related custom plugins installed. 

Thanks.

0
Comment actions Permalink

I'm using WebStorm 2021.3.2 Build #WS-213.6777.57. Is there a known issues related to what I'm talking about that the EAP version would fix? If not, I don't want to reinstall the program just on the offchance that a newer version might fix the problem. 

I did actually solve the problem by switching random options in the settings. I don't know which ones I switched tho. My main point however is to agree that the autocomplete functionality has become so complex that its unmanageable. Do you need more unit testing? More UI review? Something is needed because I've been a user of IntelliJ IDEs for like 10 years and I've seen this problem get worse and worse over the last few years. This is more than just a single bug, this is clearly a system pattern causing complexity and lowering the quality of the IDEs. More features doesn't always make the product better. And at this point, there are so many features in this product is hard for the user to figure out what's going on with it. I'm sure its also hard being a dev over there. But please try to convince your team that this complexity bloat is a real problem that needs to be reversed. 

0
Comment actions Permalink

 Is there a known issues related to what I'm talking about

No. Moreover, I've just tried to reproduce that on WS 2021.3.2, and it's working fine too. There is no setting that should trigger such behaviour. So, let me know if you find the appropriate parameter, so we can improve the UX here. 

I don't want to reinstall the program

You can installl EAP version in addition to the release. Moreover, you can run them simultaneously. 

My main point however is to agree that the autocomplete functionality has become so complex that its unmanageable

We constantly improve the UX, and every scenario should be examined separately. I'd be thankful if you could share more scenarios where completion is not working as you expect. 

0
Comment actions Permalink

I'm trying to get a string with nested single and double quotes in the editor like this:

"here is some text which has 'other text' within it"

I started by pasting in a string that was all double quotes, the inner ones escaped, like this:

"here is some text which has \"other text\" within it"

Now as soon as I change an inner double quote to a single quote and un-escape it intellij changes what it thinks is the matching outer quote from double to single. If I change it back intellij undoes my first change on the inner quote back to a double quote. So no matter how long I do this I can't get to where I want.

I have to trick the editor by commenting out the whole line then editing then uncommenting. I really do feel that the editor is working against me here and none of these suggestions seem to turn off this behaviour. It's an Xpath expression in a java function call.

Is there some special setting just for this case? I couldn't find any.

I would also like to turn off auto-editing of my code completely. Code completion suggestions are often useful, but I would still like to make the decision myself whether I want to take the suggestion.

0
Comment actions Permalink

Perhaps it would be a good idea to consolidate all the auto-complete kinds of things into its own settings tool where you can see everything configured in one place. Searching around for these things in the settings is no fun. It would also be great if the user could customize auto-complete rules in a way that can be exported and shared with others (or restored in other systems). Thi s would both let people experiment and get closer to their ideal behavior, as well as letting the community improve and hone these rules rather than putting that work load on your team.

0
Comment actions Permalink

Dbj

May you record a screencast? I could not reproducethat.See the gif:

 

0
Comment actions Permalink

Fresheneesz

There is such Settings pane. See **Preferences | Editor | General | Code Completion** 

All the options changed here are reflected in editor.xml file in IDE settings folder 

You can export the settings, sync them with other installations and share settings through git. See https://www.jetbrains.com/help/idea/sharing-your-ide-settings.html

0
Comment actions Permalink

Hello,

Please try to set "None" for "Reformat on paste" option in "Settings | Editor | General | Smart Keys"

 

-1

Please sign in to leave a comment.