Debug session was finished without being paused - breakpoint ignored

I've spent 10 hours on this, and have read every thread here, out on StackOverflow and whatever other articles I could find.  I just can't get this to work.

Win7 laptop, Apache 2.4, PHP 7.0.x and PhpStorm 2016.3.2.  Using Firefox with the xdebug plugin.

I have xdebug configured correctly, and Apache on my local machine is serving my website up at localhost:8080.  I have a Server set up in PhpStorm as localhost:8080.

When I launch index.php in my browser, PhpStorm is obviously listening because I can get it to halt if I set the "break at first line" option on.  But I don't want that -- I want PhpStorm to stop at the breakpoint I set in my code.

Instead, I get the message "Debug session was finished without being paused".  I tried (and tried and tried) to play with the path mappings - but no luck.

The other weird thing is that if I choose "open in browser" from within PhpStorm, the IDE insists on creating a new server at the 63xxx default port and then asks if I would approve the incoming xdebug request.  Why isn't it just using the default (localhost:8080) server I specified for the project, in settings?

Any pointers as to exactly how to get this working would be appreciated.

1 comment
Comment actions Permalink

Right after I posted this - I believe I fixed the problem.  In the xdebug add-on for FireFox, it was setting the XDEBUG_SESSION cookie value as "netbeans-xdebug".  I'm not sure where that came from.  I changed it to "PHPSTORM", and now it seems to be working.  I hope.

0

Please sign in to leave a comment.