Toggle auto-test in debugger has no effect?

Answered

HI,

I'm using the community edition (2016.3.2 64 bit). After I ran a test, I clicked the "Toggle auto-test" button in the debugger: https://www.jetbrains.com/help/img/idea/2016.3/icon_toggleAutoTest.png 

However, that doesn't seem to have any effect. I have changed the tests, I have changed the class under test, I have force-saved my files using Ctrl+S - the tests aren't rerun. What am I doing wrong?

Regards,

Christian

6 comments
Comment actions Permalink

Test will auto launch after you build the project after introducing the change. For it to happen automatically, enable Build Project Automatically option in File | Settings | Build, Execution, Deployment | Compiler settings.

2
Comment actions Permalink

Will that trigger a mvn build in maven projects?

0
Comment actions Permalink

What do you mean should trigger mvn build? Please check Configuring Triggers for Maven Goals

0
Comment actions Permalink

A visual step on what @andrey said.

For run the unit test automatically, toggle the auto-test button:

Go to: File | Settings | Build, Execution, Deployment | Compiler

And check the option "Build project automatically".

 

 

 

2
Comment actions Permalink

Do you have an idea how this could be accomplished in combination with Scala Plugin? (in the meanwhile I run in the console: $ sbt "~testOnly myRootPackage.*"  )

 

0
Comment actions Permalink

Hartmut There should be no difference with java: combination of Build Project Automatically and Toggle auto-test. 

1

Please sign in to leave a comment.