No Rails Found in SDK

I've seen other posts with this error going back to 2009, but nothing there helped me. I'm on the latest macOS and Rubymine 2016.3.

The basic issue is that when I try to run my rails project, Rubymine gives me the error: `Error running Development: my_project_name: [No Rails found in SDK]`.

I can run this app fine if I do `rails s` in the terminal. 

Here's some basic output:

$ ruby -v

ruby 2.3.3p222 (2016-11-21 revision 56859) [x86_64-darwin15]

$ gem list rails

*** LOCAL GEMS ***

autoprefixer-rails (6.7.1, 6.6.1, 6.4.0.3)
coffee-rails (4.2.1)
compass-rails (3.0.2)
dotenv-rails (2.2.0, 2.0.2)
factory_girl_rails (4.8.0, 4.7.0)
font-awesome-rails (4.7.0.1, 4.6.3.1)
interactor-rails (2.0.2)
jquery-rails (4.2.2, 4.2.1, 4.0.5)
rails (5.0.1)
rails-deprecated_sanitizer (1.0.3)
rails-dom-testing (2.0.2, 2.0.1, 1.0.7)
rails-html-sanitizer (1.0.3)
rails_layout (1.0.34, 1.0.29)
react-rails (1.10.0)
rspec-rails (3.5.2)
sass-rails (5.0.6)
sprockets-rails (3.2.0, 3.1.1)

 

So I have rails there. 

 

When I open the `Ruby SDK and Gems` Settings area, I see a list of ruby versions I have starting with "rbenv: 2.2.0" up to "rbenv: 2.3.3"

In versions 2.3.0 and below, when I look at the gems list, I see lots of gems, one of which is rails, and next to rails is a caret dropdown, that when I click it I see various rails versions (eg. in 2.3.0 when I drop down "rails" I see "rails 5.0.0.1" and "rails 4.2.5". The versions are slightly grayed out compared to the gem names themselves, as a feature of Rubymine.

In version 2.3.3 I see something slightly different. I don't have a "rails" gem, and no drop down caret, but instead I have 3 different gems called "rails-5.0.0.1", "rails-5.0.1", and "rails-4.2.5" and each of them has their own version listed next to them so it read like:

rails-5.0.0.1 5.0.0.1

rails-5.0.1 5.0.1

rails-4.2.5 4.2.5

So obviously Rubymine is treating these differently somehow.

I went and looked in the folders containing the actual gems, and there's nothing apparently different about the locations or filenames between different sets of gems. As I mentioned, everything is working fine outside of Rubymine.

So I'm stumped.  

In case it matters:

RubyMine 2016.3.1
Build #RM-163.9166.34, built on December 15, 2016
Licensed to Pete Michaud
You have perpetual fallback license for this version
Subscription is active until January 29, 2018
JRE: 1.8.0_112-release-408-b6 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

15 comments
Comment actions Permalink

I encounter similar issues, using IntelliJ IDEA, I can't create a usable Ruby on Rails run configuration, but rails s works fine from the console. In the run config, if I leave the auto-detected "Choose SDK from module: (module's name)", there's an error below "Run configuration error: no SDK specified". If I select "Other SDK", then select the only choice "rbenv: 2.3.0", then there's an error below "Run configuration error: [No rails found in SDK]".


One basic issue I see is that under Project Structure > Platform Settings > SDKs, it's not even possible to add a Ruby on Rails SDK, only JDK, Ruby SDK, or JRuby SDK (IntelliJ auto-configured rbenv: 2.3.0 which I guess is a Ruby SDK).

NB: I installed Ruby 2.3.0 with rbenv. The system version under /usr/bin/ruby is 2.0.0, but that's apparently used by macOS and can't be changed. Here's what I got from the IntelliJ terminal:

sdubois-macbook:~ sdubois$ which ruby && ruby -v
/Users/sdubois/.rbenv/shims/ruby
ruby 2.3.0p0 (2015-12-25 revision 53290) [x86_64-darwin16]
sdubois-macbook:~ sdubois$ which rails && rails -v
/Users/sdubois/.rbenv/shims/rails
Rails 5.0.1


macOS Sierra 10.12.3
IntelliJ IDEA 2016.3.4
Build #IU-163.12024.16, built on January 31, 2017
Licensed to Sébastien Dubois
Subscription is active until May 13, 2017
JRE: 1.8.0_112-release-408-b6 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

0
Comment actions Permalink

And under Project Structure > Modules > (module name), there's JRuby > JRuby on Rails which has been created (although it's not JRuby but Ruby), but it shows an error message "No Ruby interpreter configured for the module (module name)". There's no way to get rid of this error, even if I click '+' then reselect/Users/sdubois/.rbenv/shims/ruby from my filesystem (when the file selection window gets closed, nothing happens).

0
Comment actions Permalink

I'm not sure your issues are the same as mine, but the support team helped me fix my issue by having my install The 2017 EAP version of Rubymine, and run that. I did that, and that version ran a series of commands (automatically) that made rails accessible to itself, and it worked using that version.

The EAP version was too unstable to actually use, so I went back to the stable release version, and the changes that the EAP version made also fixed the issue for the stable version. In other words, installing and running the EAP version fixed the issue for both versions.

Hoe that helps!

0
Comment actions Permalink

Hey Pete, thanks for the great feedback. I just installed 2017.1 EAP, but unfortunately got the same issue. The only thing that seemed new is that when I selected (by accident) the /usr/bin/ruby interpreter (the old version needed by the macOS system), it gave a message that that version seemed corrupt. But no change when using the 2.3.0 version.

I'll contact support.

0
Comment actions Permalink

Thanks, I contacted support (https://intellij-support.jetbrains.com/hc/en-us/requests/881784) and recreating the project from scratch + reselecting the SDK manually at the project level seemed to fix it (and it also works when I switch back to 2016.3).

I still suggested them to fix these issues, which give a very poor user experience:
- it was somehow wrongly auto-detecting a JRuby configuration (with no possibility to switch back to Ruby on Rails)
- even now, when I go to Project Structure > SDKs, if I try to add a new SDK, there's no possibility to select Ruby on Rails, only JDK, Ruby, or JRuby. It's quite confusing. (why is Ruby on Rails SDK available at Module level and not at Project level?)
- nothing was happening when I was selecting the bullet beside the ruby interpreter in the Module config then clicking OK

0
Comment actions Permalink

Something that worked for me for those using version managers:

Preferences > Ruby SDK and Gems

Under your version of ruby, say "ruby-2.3.3-p222" select global

In the right hand panel select RVM or RBENV as your source.

 

Nothing else was able to solve the "No Rails Found" Error

0
Comment actions Permalink

I have the same problem. It would also be nice to debug with Pry.

0
Comment actions Permalink

@Vcardillo,

could you please check the solutions proposed by others in this thread. As for pry support, please vote for the corresponding issue:

https://youtrack.jetbrains.com/issue/RUBY-9302

 

0
Comment actions Permalink

@Olga,

Yes, none of them have worked for me. This solution does not match the UI:

"Preferences > Ruby SDK and Gems

Under your version of ruby, say "ruby-2.3.3-p222" select global

In the right hand panel select RVM or RBENV as your source."

 

There is no "global"

1
Comment actions Permalink

@Vcardillo,

sorry for such delay. In case you still experience the problem please provide more details (idea.log and screenshots from the IDE) to rubymine-support@jetbrains.com.

0
Comment actions Permalink

Same Problem here: "No Rails found in SDK". bin/rails s works.

rvm ruby-2.4.1

What did not change anything

  • deleting .idea
  • trying to select a SDK
  • xcode-select --install && gem pristine --all
  • reinstall rvm


Additionally I dont find any gems in the "External Libraries" in the Project viewer 

idea.log

2017-10-20 11:58:30,918 [65593341]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 11:58:36,044 [    173]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 11:58:36,071 [    200]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 11:58:36,071 [    200]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 11:58:36,071 [    200]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 11:58:36,072 [    201]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 11:58:36,079 [    208]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 11:58:36,080 [    209]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 11:58:36,080 [    209]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 11:58:36,080 [    209]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 11:58:36,095 [    224]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 15 ms
2017-10-20 11:58:36,097 [    226]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 11:58:39,584 [   3713]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 11:58:41,382 [   5511]   INFO - .intellij.idea.IdeaApplication - App initialization took 5865 ms
2017-10-20 11:58:41,558 [   5687]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 11:58:44,541 [   8670]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 11:59:32,248 [  56377]   INFO -  #git4idea.commands.GitHandler - cd /Users/mk/Development/ishap
2017-10-20 11:59:32,248 [  56377]   INFO -  #git4idea.commands.GitHandler - git -c core.quotepath=false add --ignore-errors -- app/models/company_relation.rb
2017-10-20 11:59:38,640 [  62769]   INFO -  #git4idea.commands.GitHandler - cd /Users/mk/Development/ishap
2017-10-20 11:59:38,640 [  62769]   INFO -  #git4idea.commands.GitHandler - git -c core.quotepath=false add --ignore-errors -- db/migrate/20171020094133_create_company_relations.rb
2017-10-20 12:00:29,296 [ 113425]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 12:14:59,983 [    166]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 12:15:00,011 [    194]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 12:15:00,011 [    194]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 12:15:00,011 [    194]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 12:15:00,011 [    194]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 12:15:00,018 [    201]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 12:15:00,019 [    202]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 12:15:00,019 [    202]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 12:15:00,019 [    202]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 12:15:00,034 [    217]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 15 ms
2017-10-20 12:15:00,037 [    220]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 12:15:03,367 [   3550]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 12:15:05,036 [   5219]   INFO - .intellij.idea.IdeaApplication - App initialization took 5594 ms
2017-10-20 12:15:05,216 [   5399]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 12:15:08,055 [   8238]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
    at com.intellij.idea.IdeaApplication$IdeStarter$2.run(IdeaApplication.java:354)
2017-10-20 12:18:41,861 [ 222044]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 12:18:46,015 [    175]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 12:18:46,043 [    203]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 12:18:46,043 [    203]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 12:18:46,043 [    203]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 12:18:46,043 [    203]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 12:18:46,050 [    210]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 12:18:46,050 [    210]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 12:18:46,050 [    210]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 12:18:46,050 [    210]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 12:18:46,065 [    225]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 14 ms
2017-10-20 12:18:46,067 [    227]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 12:18:49,438 [   3598]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 12:18:50,966 [   5126]   INFO - .intellij.idea.IdeaApplication - App initialization took 5467 ms
2017-10-20 12:18:51,156 [   5316]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 12:18:54,367 [   8527]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 12:20:42,592 [ 116752]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 12:20:51,633 [    171]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 12:20:51,659 [    197]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 12:20:51,659 [    197]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 12:20:51,659 [    197]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 12:20:51,659 [    197]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 12:20:51,666 [    204]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 12:20:51,667 [    205]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 12:20:51,667 [    205]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 12:20:51,667 [    205]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 12:20:51,685 [    223]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 18 ms
2017-10-20 12:20:51,687 [    225]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 12:20:55,076 [   3614]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 12:20:56,687 [   5225]   INFO - .intellij.idea.IdeaApplication - App initialization took 5589 ms
2017-10-20 12:20:56,850 [   5388]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 12:20:59,700 [   8238]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 12:34:00,581 [ 789119]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 12:34:07,367 [    195]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 12:34:07,394 [    222]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 12:34:07,394 [    222]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 12:34:07,394 [    222]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 12:34:07,394 [    222]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 12:34:07,402 [    230]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 12:34:07,402 [    230]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 12:34:07,402 [    230]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 12:34:07,402 [    230]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 12:34:07,417 [    245]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 15 ms
2017-10-20 12:34:07,419 [    247]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 12:34:10,963 [   3791]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 12:34:12,854 [   5682]   INFO - .intellij.idea.IdeaApplication - App initialization took 6083 ms
2017-10-20 12:34:13,037 [   5865]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 12:34:15,883 [   8711]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 12:40:27,240 [ 380068]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 12:40:34,380 [    238]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 12:40:34,418 [    276]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 12:40:34,418 [    276]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 12:40:34,418 [    276]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 12:40:34,418 [    276]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 12:40:34,426 [    284]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 12:40:34,427 [    285]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 12:40:34,427 [    285]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 12:40:34,427 [    285]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 12:40:34,443 [    301]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 16 ms
2017-10-20 12:40:34,446 [    304]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 12:40:37,898 [   3756]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 12:40:39,583 [   5441]   INFO - .intellij.idea.IdeaApplication - App initialization took 5890 ms
2017-10-20 12:40:39,763 [   5621]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 12:40:43,210 [   9068]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 12:57:10,764 [ 996622]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 12:57:13,885 [    172]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 12:57:13,912 [    199]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 12:57:13,912 [    199]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 12:57:13,912 [    199]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 12:57:13,912 [    199]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 12:57:13,922 [    209]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 12:57:13,922 [    209]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 12:57:13,922 [    209]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 12:57:13,922 [    209]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 12:57:13,938 [    225]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 16 ms
2017-10-20 12:57:13,940 [    227]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 12:57:17,409 [   3696]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 12:57:19,062 [   5349]   INFO - .intellij.idea.IdeaApplication - App initialization took 5731 ms
2017-10-20 12:57:19,234 [   5521]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 12:57:22,522 [   8809]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 13:00:05,503 [ 171790]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------
2017-10-20 13:00:59,270 [    172]   INFO -        #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2017-10-20 13:00:59,297 [    199]   INFO -        #com.intellij.idea.Main - IDE: RubyMine (build #RM-143.1559.2, 22 Dec 2015 00:00)
2017-10-20 13:00:59,297 [    199]   INFO -        #com.intellij.idea.Main - OS: Mac OS X (10.12.6, x86_64)
2017-10-20 13:00:59,297 [    199]   INFO -        #com.intellij.idea.Main - JRE: 1.8.0_40-release-b108 (JetBrains s.r.o)
2017-10-20 13:00:59,297 [    199]   INFO -        #com.intellij.idea.Main - JVM: 25.40-b25 (OpenJDK 64-Bit Server VM)
2017-10-20 13:00:59,304 [    206]   INFO -        #com.intellij.idea.Main - JVM Args: -Dfile.encoding=UTF-8 -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Xverify:none -Xbootclasspath/a:../lib/boot.jar -Xms128m -Xmx1024m -XX:MaxPermSize=250m -XX:+UseCompressedOops -Djb.vmOptionsFile=/Applications/RubyMine.app/Contents/bin/rubymine.vmoptions -Didea.java.redist=custom-jdk-bundled -Didea.home.path=/Applications/RubyMine.app/Contents -Didea.executable=rubymine -Didea.platform.prefix=Ruby -Didea.paths.selector=RubyMine80
2017-10-20 13:00:59,304 [    206]   INFO -        #com.intellij.idea.Main - ext: /Applications/RubyMine.app/Contents/jre/jdk/Contents/Home/jre/lib/ext: [cldrdata.jar, dnsns.jar, jaccess.jar, localedata.jar, meta-index, nashorn.jar, sunec.jar, sunjce_provider.jar, sunpkcs11.jar, zipfs.jar]
2017-10-20 13:00:59,305 [    207]   INFO -        #com.intellij.idea.Main - ext: /System/Library/Java/Extensions: [AppleScriptEngine.jar, dns_sd.jar, j3daudio.jar, j3dcore.jar, j3dutils.jar, jai_codec.jar, jai_core.jar, libAppleScriptEngine.jnilib, libJ3D.jnilib, libJ3DAudio.jnilib, libJ3DUtils.jnilib, libmlib_jai.jnilib, mlibwrapper_jai.jar, MRJToolkit.jar, vecmath.jar]
2017-10-20 13:00:59,305 [    207]   INFO -        #com.intellij.idea.Main - ext: /usr/lib/java: [libjdns_sd.jnilib]
2017-10-20 13:00:59,323 [    225]   INFO -        #com.intellij.idea.Main - JNA library loaded (64-bit) in 18 ms
2017-10-20 13:00:59,324 [    226]   INFO -        #com.intellij.idea.Main - initializing environment
2017-10-20 13:01:02,745 [   3647]   INFO - llij.ide.plugins.PluginManager - Loaded bundled plugins: CSS Support (143.SNAPSHOT), CVS Integration (11), CoffeeScript (2.0), Database Tools and SQL (1.0), EditorConfig (1.0), Gherkin (999.999), Git Integration (8.1), GitHub (143.1559.2), HAML (143.SNAPSHOT), HTML Tools (2.0), IDEA CORE (143.SNAPSHOT), IntelliLang (8.0), JavaScript Debugger (1.0), JavaScript Intention Power Pack (0.9.4), JavaScript Support (1.0), LESS support (143.SNAPSHOT), Perforce Integration (2.0), Puppet Support (VERSION), REST Client (143.SNAPSHOT), Remote Hosts Access (0.1), Ruby CSS Support Integration (143.SNAPSHOT), Ruby Code Coverage (143.SNAPSHOT), Ruby Cucumber support (143.SNAPSHOT), Ruby Database Support Integration (143.SNAPSHOT), Ruby HAML Support Integration (143.SNAPSHOT), Ruby JavaScript Debugger Integration (143.SNAPSHOT), Ruby Remote SDK Support (0.1), Ruby Slim Support Integration (143.SNAPSHOT), Ruby UML Support Integration (143.SNAPSHOT), RubyMotion support (143.SNAPSHOT), SASS support (143.SNAPSHOT), SSH Remote Run (0.1), Slim (VERSION), Stylus support (999.999), Subversion Integration (1.1), Task Management (1.0), Terminal (0.1), TextMate bundles support (VERSION), UML Support (1.0), Vagrant (0.6.VERSION), hg4idea (10.0)
    at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:194)
    at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:60)
2017-10-20 13:01:04,436 [   5338]   INFO - .intellij.idea.IdeaApplication - App initialization took 5680 ms
2017-10-20 13:01:09,519 [  10421]   WARN - om.intellij.util.ProfilingUtil - Profiling agent is not enabled. Add -agentlib:yjpagent to idea.vmoptions if necessary to profile IDEA.
2017-10-20 13:01:10,278 [  11180]   INFO - tartup.impl.StartupManagerImpl - /Users/mk/Development/ishap/.idea/misc.xml case-sensitivity: false
2017-10-20 13:01:12,108 [  13010]   INFO -         #git4idea.commands.Git - VirtualFile for path [.idea/.name] is null

0
Comment actions Permalink

@Martin Kufner before trying to create the project, also make sure that the rails gem is first installed correctly, i.e. that rails is in your Gemfile and that you have run `bundle install`. Then create project from scratch. From what I remember, IntelliJ isn't intelligent enough to do this itself.

0
Comment actions Permalink

same headache here.  i suspect it was caused by installing rubymine before rvm.  

 

what worked for me to fix it:

1) move/delete .Rubymine* in your home directory

2) delete .idea in the project directory 

 

i didn't try twice, but i think that 1) is the main fix.  

 

0
Comment actions Permalink

You might also want to consider whether you have the same Ruby version in your terminal as you do in your project.

For example, I set my project to Ruby 2.3.5, but because my global default is Ruby 2.4.2, that's what I have in the terminal until I change it.

It gave me hours of misery until I worked it out.

0
Comment actions Permalink

I upgraded to Rubymine 2018 and the problem was solved.

0

Please sign in to leave a comment.