sbt projects no longer work - Rolled back to 2016.3.1

After yesterday's ( Feb 1st update) IDEA is no longer capable dealing with Scala libraries if the project is imported from SBT.

I created a very simple SBT project, the highlighting worked as though Scala libraries are not visible, at the same time it compiles and runs OK from IDEA.

When I use the same sources without SBT, i.e. when I removed everything SBT related and created project "from existing sources" it worked fine.

Reinstalled 2016.3.4 - still does not work

Rolled back to 2016.3.1 - works just fine



Which version of the Scala plugin are you using?

When you created "project from existing sources", did you use the SBT import, or manually add the Scala library?


1. Can't tell without installing 2016.3.4 again. I installed if afresh so I assume it has downloaded the latest version of Scala plugin

2. I tried both, SBT import did not work but "project from existing sources" did (in abscense of SBT scripts, I deleted them), in later case I used global Scala library. The same SBT project was is imported by freshly installed 2016.3.1 without any problems. 


I'm afraid I can't reproduce this problem.

A thing you can try is the File / Invalidate Caches / Restart menu option, it seems like the caches used for highlighting might have been broken somehow.

Hint: The JetBrains Toolbox App makes using multiple versions of IDEA and our other products easy.


Please sign in to leave a comment.