Validate debugger Configuration on Web Server, "no php.ini file was found"

Answered


i can use xdebug to debug single php file.

but when i want to debug on web server.i can not Validate debugger Configuration on Web Server.

the message is :

No php.ini file was found

No debug extension is loaded



 

 

6 comments
Comment actions Permalink

Hmm...

What phpinfo(); output shows (when captured via browser)?

0
Comment actions Permalink

the phpinfo(); shows my apache still use PHP 5.6.25 not PHP7.1

i use  "brew install homebrew/php/php71" to install 7.1.so i think it's some thing wrong with my macOS apache sever.

0
Comment actions Permalink

Sorry, no much help on this one from me -- not a Mac user at all.

But generally speaking it could be:

1) You have 2 or more different PHP installations on your system

2) You still have not restarted Apache (in case if it's needed after updating PHP, assuming that it meant to replace current one)

3) Your Apache uses that old PHP on purposes .. so you need to manually configure it to use new one

0
Comment actions Permalink

ok.i confirmed 3 point. my Apache uses that old PHP.

my new Validate Debug Configuration on Web Server.

 

 

This is my xdebug config.




i'm sure that PhpStrom have tool-> deployment-> Automatic Upload  selected.(means my macOS local apache server have same code as my project)

 

but when run debug, the PhpStrom stick show "waiting for incoming connection with ide key '13045'"

but i have config xdebug with idekey= PHPSTROM.

it's really feeling very confused....

======================================================================

Steps as bellow pictures shows:

1. i run debug

2.change xdebug helper ide key to "16744"

3.enable xdebug helper -> debug (button get green).

3.reload page (https://localhost:8080:test/php)

but there is nothing response.

Can you give me some idea?

 

 

 

0
Comment actions Permalink

>but when run debug, the PhpStrom stick show "waiting for incoming connection with ide key '13045'"

That's how Run/Debug Configuration of Web Application type works -- it uses random keys.

I'd recommend using Zero-config approach (when you use "phone handle" icon in IDE and xdebug extension in browser:

But for the actual issue:

1) please collect xdebug log for such unsuccessful debug session: https://xdebug.org/docs/all_settings#remote_log

2) Show your phpinfo(); output captured via browser (full xdebug section at very least)

3) Show your IDE settings (PHP | Debug, PHP | Servers)

Right now there is still something missing (config) . or xdebug does not try to connect to IDE (does not see cookie etc .. or firewall/etc)

 

P.S. And try to close previous debug session tabs before running new one -- maybe it's still there somewhere?

P.P.S. Since it all happens on the same computer (no VM/container/another server) .. you may also try disabling "connect back" option and set remote_host to be 127.0.0.1 (in case if your Mac gives IPv6 a priority over IPv4)

0
Comment actions Permalink

hi Andriy, Sorry for late reply . Thank you very much  , i GOT the Breakpoints with your advices!!!!!!!!!

0

Please sign in to leave a comment.