DataGrip not list tables


 I'm using 

DataGrip 2016.3.3
Build #DB-163.12455.1, built on January 25, 2017
Licensed to chenxiaoyu

JRE: 1.8.0_112-release-408-b6 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o


when expanding one MySQL datasource, DataGrip not list the tables. But it works for all querys(returning right results).

The error shows in console is "No matching function with signature: user()..".


This MySQL server is some custom, but it worked fine in other DB tool like phpMyAdimin. Also, it is all good expect the table listing.

The "AIP - stat" works fine, but "AIP palo" is not.


Comment actions Permalink


Could you specify your data source settings or connection string?
What do you mean under "some custom"?

Thank you.

Comment actions Permalink

I have the same issue that Database tree view does not show tables. I am using DataGrip 2018.1.2. I have tried several approaches obtained from the web but to no avail. Can someone help?

Comment actions Permalink

From my research, there are many reasons the tables may not display. I had this problem and have been working on it for days... the solution for me (for everyone's reference) was to "Force Refresh" (Alt+Shift+Command+R on macOS). Find it in the context menu of the database connection under "Diagnostics". See screenshot.


Please sign in to leave a comment.