Cannot reload rake tasks list


When I go to run a rake task, there is nothing in the list except a drop down with the "refresh logo" with the text "Reload rake tasks list", but I cannot select it or figure out how to reload the empty list so I can use migrate. Please help!


OK figured it out myself... Had to go to RubyMine->Preferences->Project Structure and change Content Root to be the directory that contained the Gemfile. Then I ran Tools->Bundler->Install (not sure if this step was required, but found it along my troubleshooting path. It gave output saying it couldn't find the Gemfile which led me to the eventual solution). Then the rake tasks lists will populate itself!


I have the same problem, namely, an empty rake list.  I followed your (Asorgiu's) instructions and added a "content root" and then re-ran bundle install.  However, opt-R still gives me an empty rake list.  I double clicked on reload rake tasks and RubyMine has been running the process "generating rake tasks hierarchy" FOR HOURS.  

How long does it take to re-generate the rake tasks hierarchy, or has RubyMine "hung" (as I suspect)?





could you please specify what RubyMine version you're using (and whether you've tried the last one). Does it happen to all your RoR projects?


Same problem here:

Error:[rake --tasks] rake aborted!
/Users/augustocbx/.rvm/rubies/ruby-2.4.6/lib/ruby/site_ruby/2.4.0/bundler/runtime.rb:81:in `new'

RubyMine 2020.3.2
Build #RM-203.7148.67, built on January 26, 2021
Subscription is active until May 6, 2021.
Runtime version: x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 10.16




Augustocbx, according to the error message your issue differs so it'd better to submit it separately on our tracker if it persists in the latest RubyMine versions (2021.3/2021.2.3): 


Please sign in to leave a comment.