Ubuntu - Mouse gets 'stuck/inverted' after a while



It often happens (after 10-30 minutes) that my mouse seems to get 'stuck' in a way that it can't click on anything anymore, and the left mouse 'hangs' so it selects everything in the coding part if move the mouse. Only the File/Edit/View etc dropdowns respond to left mouse click, but no popups or file tabs etc

All other running applications work fine, only webstorm is affected. Restarting Webstorm also doesn't help, neither ctrl+alt+F1 / ctrl+alt+F2 after reading a bit similar problem on SO 


Anyone else having the same? Its really annoying because the only fix for now is a full reboot! :( 


Could be I do an accidental touchpad gesture (new laptop, xps 9560). But still its really frustrating.

Many thanks!




Thanks it does sound the same indeed.


Will keep an eye on it.


Do you recommend any JDK fix/version I could use to squash the bug?  




This bug is not fixed, so I can't suggest any JDK build that is free of it



  1. Touch your touch screen.
  2. Boop!

Can't guarantee it'll work for you, but this bug has been driving me nuts forever.  Found this fix on the Atom issue tracker for the same problem.


@Eode: Thank you!!! You have no idea how many reboots I have done to get over this; and all it took was a touch of the screen! Works like magic! TY!TY!



Ha - I rebooted my machine yesterday to get around this, if it happens again will poke the screen...


touchpad gesture is seen when we window update and it happens when a new version update and its diver has been affected. So you can check window and driver. I have the same problem my hp touchpad not working and could solve with help of its support center


Just rescued my sanity on a linux mint HP laptop with a touchscreen that lives in clamshell mode 99.9% of the time. Even has the touchpad turned off but this fixed it.


Follow this issue if you are experiencing this issue: https://youtrack.jetbrains.com/issue/JBR-563

More followers = more attention to fixing the issue.


Thank you @Eode!

I was left wondering, has it always worked that way!?




Eode Logged in especially to thank you! This was driving me nuts!


Will some JetBrains staff member clean up this SEO SPAM?


Please sign in to leave a comment.