The git branch bane doesn't appear on the bottom-right corner

Answered

Hi,

 

For some reason my Idea doesn't display the current git branch in the bottom-right corner - 

Can you help me make it appear again?

Thanks in advance,

Ron

39 comments
Comment actions Permalink
Official comment

Enabling the Status Bar via the View menu fixes the problem.

Comment actions Permalink

Do you have Git enabled for the project in the Version Control settings?

3
Comment actions Permalink

I do.

All the git actions work properly. only the branch banner doesn't appear.

0
Comment actions Permalink

It looks like a bug(?) in the bottom banner. Other displays are broken aswell - 

0
Comment actions Permalink

Please report a bug at https://youtrack.jetbrains.com/issues/IDEA with idea.log (https://intellij-support.jetbrains.com/hc/articles/207241085) and the screenshot of the problem attached. Thank you.

0
Comment actions Permalink

I also faced this issue for 3-4 days in Intellij IDEA community version 2020.1.1 then I found a option in View -> Appearance -> Status Bar Widgets -> Git Branch. This did the fix.

18
Comment actions Permalink

I had similar experience which was due to a wrong proxy password. It would be nice to get some message telling about wrong proxy password.

0
Comment actions Permalink

I had similar issue. I had checked View -> Appearance -> Status Bar Widgets -> Git Branch and I still could not see branch name in the bottom right corner.

For me checking the View -> Appearance -> Status Bar option fix the problem.

6
Comment actions Permalink

Jan Przybysz thanks, amazing that basically the only way to know what branch you're on is a) off by default, and b) hidden below 4 menu levels.

Thanks for discovering it!

David

 

1
Comment actions Permalink

Thanks for the answers guys, worked for me as well.

0
Comment actions Permalink

Thanks a lot guys, Its Working. Thank you.

0
Comment actions Permalink

It might sound obvious, but might be not, on the bottom bar there are two panels, and in some cases you might not realize that, and having a window moved a little bit off the screen might hide this panel, as a consequence it looks like as if the here mentioned suggestions didn't work, or in a combination of these issues.

2
Comment actions Permalink

I finally fixed this by editing the .idea/workspace.xml file and remove the complete `<component name="Git.Settings"/>` entry.

3
Comment actions Permalink

For me works only to completely delete the folder .idea from project root.

0
Comment actions Permalink

Tried everything here - wasn't working.  Not sure why, but I dug into the 'Preferences' and went down to the 'Version Control' option and I noticed there were no entries listed.  So, I clicked the '+' Sign and added the project directory and voila!  It appeared.   The View menu won't have any entry for Git unless this is done.  

0
Comment actions Permalink

It seems like it happened to me after I removed .idea folder at repo cleanup on my disk.

Follow @bbqchickenrobot advice from above, it should help 

0
Comment actions Permalink
 View --> Appearance --> Status Bar [and click to enable/disable]
 
0
Comment actions Permalink

In my case the problem was that the Git plugin somehow got disabled after my computer's update. After enabling it, everything works fine.

0
Comment actions Permalink

Fantomx1 Hahaha! Thank you so much! You spared me from wasting so much time trying to figure what was wrong before I realize my IDE window was a slightly off the screen! :D :D

0
Comment actions Permalink

In my case, Rider 2021.3 changed the default Toolbar layout and only the Toolbar Classic keeps the git branch information in the bottom right corner.

View | Appearance -- Toolbar/Toolbar Classic/Navigation

https://youtrack.jetbrains.com/issue/RIDER-73155#focus=Comments-27-5697043.0-0

5
Comment actions Permalink

I've just updated to Build #IC-213.6461.79, built on December 28, 2021 as well

the Git branch is missing in the status bar.

None of the above fixes works though.

 

Which GIT Plugin are you all using to get the branch to appear?

There are 100s

 

 

 

 

0
Comment actions Permalink

Cappy2112 
Do you have Git repository initialized in your project? 

Git plugin should be bundled:


0
Comment actions Permalink

Konstantin Annikov

Yes, I have a git repo mapped, but the branch still does not appear in the status bar.

0
Comment actions Permalink

What does `git status` command show if you run it in the directory specified on your screenshot?

0
Comment actions Permalink

git is fine

I've been committing/pushing in that directory since 8AM today

"Your branch is up to date with 'origin"

 

0
Comment actions Permalink

FYI, The same thing happened with PyCharm with the latest update.

The git status bar is gone. Both IDE's were updated in the same day.

The previous versions of both IDEs-worked fine. That is, the git status bar was visible in the lower right corner

0
Comment actions Permalink

Please file a bug at https://youtrack.jetbrains.com/newIssue?project=IDEA with the logs attached (Help | Collect Logs and Diagnostic Data).

0
Comment actions Permalink

Serge Baranov No need to file a bug report.

I noticed a small popup in the upper right corner, one that I've never seen before.  "Trust Project"

Once I agreed, the IDE display shifted slightly, now the branch name shows in the bottom right (for both Intellij and Pycharm)

Very strange.

 

0

Please sign in to leave a comment.