The git branch bane doesn't appear on the bottom-right corner

Answered

Hi,

 

For some reason my Idea doesn't display the current git branch in the bottom-right corner - 

Can you help me make it appear again?

Thanks in advance,

Ron

6
41 comments

Cappy2112

If you haven't trusted to a project then Git integration will be also disabled. So you have 'Trusted" to a project and IDE opened it for you in full mode.
Please see:
https://www.jetbrains.com/help/idea/project-security.html#safe_mode_limitations

0

In my case I got the git branch back by right-clicking the status bar and selecting "Git Branch". Not sure how it got unselected...

0

This is happening for me on Rider 2022.1.2. Project is trusted, git is enabled for the project, 'Git Branch' is not listed in View -> Appearance -> Status Bar Widgets. Committing, Pushing, changelists, git history, all work fine. Removing the git aspects of workspace.xml and restarting did not work either.

EDIT: I'm dumb. It just moved locations to the top left corner, for some reason.

0

Joseph Brooksbank Could you please share screenshot of your window? 

0

As I said in the edit, I found the new location of the git branch indicator. I expected the git branch to be in the bottom right (red), but it has moved to the top left (green).

0

Joseph Brooksbank

Please try to turn on the new toolbar in `View | Appearance | Toolbar` (instead of "Toolbar Classic") for now. The widget is included in the new toolbar. 

1

Sorry, maybe I wasn't clear. I don't have an issue anymore. I came to this thread but found the solution on my own shortly after. As you can see in the screenshot I posted, the git branch is visible.

0

When I fight with this kind of 'problems I could have stayed with eclipse. Git Integration there is better solved as in the expensive Ultimate Intellij. Basic Tool that everybody is using and I am searching for days to find the solution. :(

0

Stephan Avigue could you please elaborate what problem do you mean? As there are several mixed in this thread.

0

I had same problem. Disabling "Toolbar" sorted it out.

Deselect: View|Appearance|Toolbar 

 

 

0

You can enable it in IntelliJ 2023 → View → Apperance -→ Status Bar Widgets → Git Branch

0

Please sign in to leave a comment.