Disable Auto Transpiling TS to JS

For some reason Webstorm keeps transpiling my typescript files to javascript.  It's not a big deal, but it seems to slow down the IDE a bit and I get periods of hanging that occur.

I'm already using webpack to transpile, so I don't want this feature enabled.


How do I disable automatic TS to JS transpiling?

19 comments
Comment actions Permalink

Make sure that 'Enable TypeScript compiler' is disabled in Preferences | Languages & Frameworks | TypeScript, and that you don't have TypeScript file watcher set up in Preferences | Tools | File Watchers

1
Comment actions Permalink

Thanks Elena!  That worked!

0
Comment actions Permalink

Hey Elena can you let m know how to do the same in Webstorm because I don't find to enable typeScript compiler in languages & framework in preferences.

 

0
Comment actions Permalink

In WebStorm 2018.1.x, it's Preferences | Languages & Frameworks | TypeScript, Recompile on changes

 


3
Comment actions Permalink

Thanks Elena . It worked.

1
Comment actions Permalink

can I enable TypeScript Language Service and disable Javascript generation?

0
Comment actions Permalink

Seems like it doesn't work with TypeScript references with emitDeclarationOnly, for instance, in lerna projects. We need to recompile on each change into dist folder in each learna package, so Recompile on Change flag should be checked, but it should not produce .js files, like WS does now

0
Comment actions Permalink

please can you provide your tsconfig.json?

0
Comment actions Permalink

Hi, It seems to still compile in JS for me,
even though the "recompile on changes" check is off.

What can I do?

0
Comment actions Permalink

see if you have any file watchers set up

0
Comment actions Permalink

won't that disable the rest of the typescript language services from working?

0
Comment actions Permalink

haven't got what you mean, sorry... disabling "recompile on changes" doesn't disable services

0
Comment actions Permalink

 

Ok, I think this was created by the Nativescript run command

1
Comment actions Permalink

Hello!

After every new startup Recompile on changes is turned on again. I supposed that it is because file watcher, but the trouble is that I do not have File Watcher as stated previously in Preferences | Tools | File Watchers . BUT In my Idea 2019.1.2 Ultimate Edition it is missing? How can I disable it in my case?

Thank you

0
Comment actions Permalink

>After every new startup Recompile on changes is turned on again.

seems IDEA has troubles updating your project .xml files... do you have .idea\compiler.xml in your project, what does it look like? Do you version control this file?
Also, please can you try recreating the issue and attach the idea.log?

1
Comment actions Permalink

I am having the same issue. Recomplor-on keeps turning on and transpiling occurs.

0
Comment actions Permalink

This is not working for me. I have disabled "Recompile on changes" and have no file watchers. It wouldn't be a big issue if it weren't for the debugger behaviour. Adding a breakpoint does nothing and if I add a "debugger" it stops but in the js file.

0
Comment actions Permalink

>I have disabled "Recompile on changes" and have no file watchers. 

It must be some other tool then. Make sure that no watchers are run for your project

>It wouldn't be a big issue if it weren't for the debugger behaviour. Adding a breakpoint does nothing and if I add a "debugger" it stops but in the js file.

haven't got how it's related to disabling the auto-transpiling.

Please share a project that can be used to recreate the issue

0

Please sign in to leave a comment.