No version control tool window but Git is still enabled?!


So I have in my Idea some git functionality, eg in the bottom right corner of Idea I can see the branches in a drop-down-control and I can right-click in the source code and choose Git -> Annotate which will decorate the editor with the Git-annotations. But there is no Version Control Tool Window, so I cannot inspect my git history (eg). The version control tool window is normally accessable via View -> Tool Windows -> Version Control, but it is greyed out (disabled).

BTW there IS NO OPTION to "Enable Version Control" in the VCS meny (and why would there, git seems to be already enabled, it is just the Version Control Window thats is missing).

Any ideas?

IntelliJ Idea 2016.3.4 (Build #IU-163.12024.16) Mac OS X



Please try the following:

  1. Go to Preferences - Version control
  2. Delete all VCS roots registered there
  3. Apply changes
  4. Register all roots once again.

I've experienced this on 2018.02 (Build #IU-182.4323.46).

Easiest solution is to open it via action popup (ctrl+shift+a, search for "Version Control").


ctrl+shift+a and searching for Version control works!


@Team please fix this, same for me. VCS tab not available by default for Git project


you can try alt+9 , this one is more convenient

i have this problem too


I'm experiencing the same issue.

PyCharm 2019.3 (Professional Edition)
Build #PY-193.5233.109, built on November 28, 2019
Runtime version: 11.0.4+10-b520.11 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.15.2


Just did the latest minor update and lost my Version Control Tool Window!

How do I get it back as all the suggestions above do not work. It doesn't show up in help or view menu either.

PHPStorm 2019.3.1


Wagner Correa & Matt Eschenbaum could you please provide steps to reproduce the issue, when do you see such behavior? 


I can also confirm this. I just updated the IDE and after the restart IDE lost its Version Control tab.

About info:

IntelliJ IDEA 2019.3.1 (Ultimate Edition)
Build #IU-193.5662.53, built on December 18, 2019
Licensed to TransPerfect Translations / Jovan Cvetkovic
Subscription is active until September 9, 2020
Runtime version: 11.0.5+10-b520.17 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.4.5-050405-generic
GC: G1 Young Generation, G1 Old Generation
Memory: 1152M
Cores: 12
Non-Bundled Plugins: BashSupport, JSSorter, com.alayouni.ansiHighlight, com.bluewaitor.tsReact, com.bobz.OpenTerminalHere, com.cybrosis.catdea, com.huangmb.idea.fineI18N, com.intellij.ideolog, com.ivanovych666.intellij.plugin.jsonsorter, com.jinsihou.react.snippets, com.kotcrab.quicklaunch, com.marlboro.gitbar, com.thvardhan.gradianto, com.wix.react-templates, eu.osimowicz.plugins.intellij.CodeBlocksSorter, net.ashald.envfile, oorg.bvic23.intellij.plugin.storybook.Storybook, pl.lksztmczk.openinterminal


Just tried solution from and then did update afterwords and the tab re-appeared for me.


In 2019.3.1 the Version Control toolwindow is initialized in a lazy asynchronous way. It might cause issues in some cases. The issue should be fixed in 2019.3.2, please check if it works in 2019.3.2. EAP is available already.

Related issue -


I also faced the impossibility to view the 'Version Control' tab in Community Edition 2019.3.1 .

I have solved it by using from meniu: File -> Invalidate Caches / Restart ...


Solution specified by Mihai Craciun KnallJanuary 3, 2020 worked for me.


Yep, invalidating cache did help.

PyCharm 2019.3.2 (Professional Edition)
Build #PY-193.6015.41, built on January 21, 2020
Runtime version: 11.0.5+10-b520.30 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.3.0-28-generic


This exact problem (branches visible in bottom right, but no VCS functionality) happens for me only when I have multiple projects attached to the same window.

When I go to Preferences -> Version control, the project shows up as an unregistered VCS root, and I am unable to enable it.

Current solution working for me: detach the project, then when re-opening, open as new window (or this window). VCS functionality starts working by itself after that.


Found it!

I'm running IntelliJ Idea 2020.1. 

Alt+9, which used to bring up the old Version Control tool window, now displays the new Git tool window (or whatever VCS you are using), which does not display a list of changed files or their differences.

But there is a new tab on the left, next to your Project and Structure tabs, called Commit. It does list all your changed files, but doesn't automatically display differences. You can use Ctrl+D from there to do that. You can also commit, roll back, and do many other VCS functions from there.


> You can use Ctrl+D from there to do that

You can just double-click to open Diff preview in the editor.


The biggest failing of the Commit window that I can see is the inability to open a file in non-diff mode from there.



You can use Jump to Source (F4) to open the file from Commit toolwindow


For anyone looking to get back the old Version Control tab in 2020 (you will get back the "Local Changes" tab under "Git" at the bottom), you can do so by disabling "Use non-modal commit interface" under Version Control -> Commit in your Settings.


I think most of  the functions of version control tool window are available in commit stripe on the left , below project strip


VCS -> Enable VCS Integration


If you've opened the project without trusting it, git won't be enabled.

One way to fix that is to close the project, rename the directory, then open it again.

I wasted a good amount of time trying to figure this out. Webstorm should make the fact that git is disabled more visible - perhaps by leaving the Git/VCS menu visible, but with only one option to Trust the project.


Please sign in to leave a comment.