Xcode 8 CoreData generated entities not detected in AppCode?

Answered

Hi all,

 

Pretty much new with AppCode. I have a quick question regarding CoreData support. Xcode 8 auto-generates the code for entities created in the core date model editor. They are properly detected in Xcode, but in AppCode a get a "Use of undeclared value" message. Is this a configuration issue or an issue with AppCode at the moment?

 

Thanks.

6 comments
Avatar
Tatiana Shabaeva
Comment actions Permalink
Official comment

Hi,

That's an issue in AppCode, please vote/watch OC-14170. As a temporary workaround you may try to add a folder with auto-generated files into "User Header Search Paths" as described.

Comment actions Permalink

AppCode 2017.2 EAP
Build #OC-172.2465.14, built on May 25, 2017
AppCode EAP User
Expiration date: June 24, 2017
JRE: 1.8.0_152-release-855-b1 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.5

Установил последнюю версию 2017.2 EAP. По прежнему не работает. Мой продукт тесно связан с CoreData. Я не могу использовать ваш продукт из-за того, что он не видит объекты. Хотя сборка выполняется. Пожалуйста, почините.

Have installed the latest version 2017.2 EAP. Still not working. My product is closely linked to CoreData. I can't use your product because of the fact that he did not see the objects. Although the build is running. Please fix.

 

1
Comment actions Permalink

Thanks, while the error messages have disappeared, autocomplete on codegen objects is still not working. I'll keep track of this in OC-14179, you may close this issue,

0
Comment actions Permalink

Hi Chris,

Please contact our support email - appcode-support at jetbrains.com. We'll try to help.

0
Comment actions Permalink

I also have this issue.

0
Comment actions Permalink

I also have this issue, are we able to claim part of the license fees back due to the product not being fir for purpose?

-1

Please sign in to leave a comment.