Stopping at breakpoint causes 'Process finished with exit code 130 (interrupted by signal 2: SIGINT)'

I'm using webStorm to debug nodejs code.

When breakpoint is hit, the server will terminate. It works fine if no breakpoint hit.

I tried to reinstall webstorm, the same issue.

(node v5.6.0

WebStorm 2016.3.4
Build #WS-163.13906.20, built on March 7, 2017

OS: Mac OS 10.11.2 (15C50)

Anyone can help me?

Thanks

Shunchen

10 comments

if no breakpoint hit, it works fine.

0

what does your run configuration look like? Please attach a screenshot

0

It happens to me when there's some Watches that Webstorm does'nt like. Clean all your watches and try

0

Having the same issue on 2017.3 EAP. Trying to start a debug session for a unit test gets instantly killed with exit code 130. Went back to the stable version 2017.2.4 and it works flawlessly there. 

0

Can't recreate.

What test runner do you work with - Mocha, karma, Jest, etc.? What Node.js version is used?

Sample project that shows up the issue plus your idea.log would be helpful

 

0

I just tried Webstorm 2017.3 EAP (WS-173.2696.21) and it seems to work now. I have a NodeJS project with Mocha tests and can run and debug them just fine now...

0

This is happening to me quite frequently in WebStorm 2017.2.5, but also happened frequently before. I get no information other than:

Process finished with exit code 130 (interrupted by signal 2: SIGINT)

WebStorm 2017.2.5
Build #WS-172.4343.25, built on October 20, 2017
JRE: 1.8.0_152-release-915-b12 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.6

Any ideas on how to fix or ways I can get more info about what's causing the issue? It makes debugging pretty tedious.

My project is not that complex but has some features that may help destabilize the environment, especially using node-java so that I can call some Java code, but this is generally happening before that code is even hit.

One thing is that this doesn't seem to happen, or at least not as often, when I connect to an application remotely.

0

This is a Node.js issue most probably... Hard to tell more, as you didn't provide any details. I'd suggest trying different Node.js versions to see if any of them works for you

0

Please sign in to leave a comment.