Find in Path/Replace in Path

Answered

In the latest version of RubyMine 2017.1 find is now opening in a modal by default.  Is there anyway to make it always display in the find window at the bottom?  I don't like the modal.  I don't like having to click the "Open in Find Window" every time I search.

14 comments
Comment actions Permalink

Agreed - would be great to have an option for the find results to appear at the bottom by default (as with prior versions.)

6
Comment actions Permalink

I agree - this is most annoying.

5
Comment actions Permalink

Pressing cm+enter still requires first opening the results in the modal.  I can also just click the button to open in find window on the bottom right.  I don't want to have to do that.  I just want the search results to appear as they used to in the find window by default.

4
Comment actions Permalink

This is anoying for all version of IntelliJ - not only RubyMine

 

I open  same on general IntelliJ

https://intellij-support.jetbrains.com/hc/en-us/community/posts/115000256944-Find-in-Path-Replace-in-Path

Got answer from above link :

`-Dide.find.as.popup=false` in Help | Edit Custom VM Options will restore the original dialog

 

 

4
Comment actions Permalink

+1, I don't like this popup, any possibilities to disable it?

3
Comment actions Permalink

It is the most useless thing in a new version. I cannot work :( Each time I see it each time I am going crazy :(

1
Comment actions Permalink

yay! finally back to how it should work!

1
Comment actions Permalink

Thanks Dany! `-Dide.find.as.popup=false` in Help | Edit Custom VM Options will restore the original dialog worked for me.

1
Comment actions Permalink

I agree with the above comments. The popup box works really well if you have a couple of matches. If you have more than that it's pretty much unworkable.

The old (docked) Find window still works after you hit Ctrl Enter so I can't see a reason why that can't be the default.

0
Comment actions Permalink

YES! Thanks, Dany (and by extension, Serge, who supplied the answer in the other thread).  This brings back the old behavior.

0
Comment actions Permalink

This is now broken with the newest release of RubyMine (2018.1) :(

After you open the finder window, you cannot type in the search box for some reason. It becomes unusable. I removed the custom command that was referenced in this post and saw that there is a newer finder window implementation. It seems better than the one that forced us to use this custom command, but still not as good as the old one. You can somewhat emulate the old window by clicking the pin in the corner to keep it floating while you go through all your find all results.

0
Comment actions Permalink

You can use the shortcut to open the results in Find Window (cmd+Enter in the default OS X keymap)

-1

Please sign in to leave a comment.