XAMPP deployment configuration

So I'm having some issues with PHPstorm, the POST method, and configuring XAMPP as the deployment and web server and everything.

 

Basically PHPStorm works perfectly, but the built in web server, no matter how simple the form, will always result in my $_POST being empty. I read there was an issue with that so they said to just use XAMPP, which I have been using. The problem is I don't know if it's setup correctly as I'm still getting these errors of undefined index or variable.

 

So I'm wondering if I haven't set up everything correctly to work with XAMPP...

 

What do I need to do besides the deployment tab in preferences? Do I need to edit configurations when I run my .php under the Run menu? I think it's still using the built in web server for PHPStorm because even the absolute most basic form using post method, all using the correct syntax, still results in "undefined variable" or "undefined index" when trying to echo out the form data.

 

These are what I have set:

 



I feel like I'm missing something.

1 comment

Hi there,

1) Well .. your last screenshot -- it still points to built-in web server -- please adjust the URL that is served by XAMPP

2) It's Run/Debug Configuration of JavaScript type -- is that's what you need?

3) BTW -- other configurations are "PHP Script" type -- they are run in CLI mode (console)...

 

Please check these links in case if you have not seen them yet:

0

Please sign in to leave a comment.