Where is **SIMPLE** tutorial on how to connect DataGrip to SQL Server Developer Edition

I cannot find a **SIMPLE** example of how to :

1. Start DataGrip from scratch, for the very first time.

2. Connect to a SQL Server 2016 Developer Edtiion (not localdb) like I do now with other tools (Visual Studio 2015, Visual Studio 2017, SQL Server Management Studio 2016) for the following connection:
"Server=.;Database=LibraryDB;Trusted_Connection=True;"

Maybe the example I'm looking for is "hiding in plain site", but when I search for "DataGrip" connect "Microsoft SQL Server", I cannot find such an example. 

The "Features" pages dives right in and assumes you have already successfully connected, but since I cannot even get that far, those "features" are useless to me.

6 comments
Comment actions Permalink

I see, that you Googled it, but what's bad about this tutorial? https://blog.jetbrains.com/datagrip/2016/06/21/connecting-datagrip-to-ms-sql-server/

If you want something simple, there is a comparison window there: 

SSMS and DataGrip

0
Comment actions Permalink

It's now June 2017 and this is still not working, even with the latest DataGrip 2017.1.4.

Here's the successful connection using SQL Sever Management Studio 2016:

And now the failed connection attempt using DataGrip 2017.1.4 :

How does JetBrains expect anyone to switch from SSMS 2016 to DataGrip 2017.1.4 if the simplest tasks such as connecting to a locally installed, default instance (NOT SQLEXPRESS!!!!) are next to impossible?

1
Comment actions Permalink

Try to put 

localhost

instead of 

.
0
Comment actions Permalink

Does not work for me either, I have the same problem.

I have managed to connect to a remote server on the first try - by IP address, not a named instance but the default one. I only had to put in the IP address of the server, nothing else. I mean besides the username and the password as the remote server uses SQL authentication.

I am yet to find out if the problem is with Windows Auth, the server being on localhost or the default instance.

I reveice the same general error as the OP. I have tried ., localhost and 127.0.0.1, to no avail.

Running DataGrip on Windows btw.

0
Comment actions Permalink

2018-09-22 - It's been 1.5 years and this issue has still not been resolved.

Bye bye DataGrip.  Nice try, but if you cannot perform the simplest things, how on earth do you ever expect to accomplish more complex tasks?

0
Comment actions Permalink

No, I think there must be a blatantly simple solution, we just haven't found it yet. I'll keep trying as I find the tool extremely comfortable to work with in connection with my daily tasks.

 Note: I have SQL Server 2017 installed.

Edit: there, I've managed to solve it. It was my bad because I was not paying attention and checked the protocols of the Native client instead of the server. The TCP/IP was of course disabled under the SQL Server Network Configuration. Upon enabling it and restarting the server, the connection was successful immediately. I did have to change the . (dot) to localhost for it to work though.

So nevermind, my problem has been solved!

0

Please sign in to leave a comment.