Pycharm 2017.1 py.test no longer working with -m option


In my unit tests I market some tests with "@pytest.mark.slow" to avoid running them except when explicitly desired.

In the setup for my PyCharm runner I set the Additional Arguments to:

    --color=yes -m "not slow"

This worked fine in PyCharm 2016, but with the new PyCharm 2017 I get the following error:

    ERROR: file not found: slow"

Can you please help. I tried using single quotes in place of double quotes but it did not help. Again this worked fine in all previous versions of PyCharm.



Encountered a similar problem running py.test tests with "-k":

  -k "TestClass and test_def"


  ERROR: file not found: and

My environment info:

IntelliJ IDEA 2017.1
Build #IU-171.3780.107, built on March 22, 2017
JRE: 1.8.0_112-release-736-b13 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.3


I submitted a bug report to JetBrains here. Please add more if you think it will help them resolve:


Please sign in to leave a comment.