WebStorm 2017.1 Hanging

 I just upgraded to Web Storm 2017.1 and all of a sudden everything hangs when trying to type code or navigate the application. You type and it hangs for 30 seconds or so, then comes to life again. 

Please advise!


Same issue here, running on OSX 


Edit: so, I'm embarrased to admit, but It resolved itself after I restarted to IDE to do the CPU snapshot. :D 


please see above. There is no chance to see if it's the same issue unless you provide snapshots (if it runs slow) or thread dumps (if it stops responding completely)


Ok so actually I have experienced it again. Here is the CPU snapshot: 


ike OP was describing, I was really just typing and using code-completion suggestions etc, the stuff that happens while typing. it was in a groovy file. The problem first occured after stopping and restarting the application a couple of times. 


please can you report the issue to Idea support? Snapshot shows that is problem is related to groovy parsing, this code is not a part of WebStorm and is not handled by WebStorm team


+1 happens to me on a angularjs project (framework: meteor). Tried to disable most plugins, it didn't help. If this keeps on going I might ditch 2017.1 and reinstall 2016.3.5 which worked great (as such, I'd classify this issue as a major regression which inhibits product use)


+1 happens to me as well. We have a rather large angular 2 project and the whole team has been using WebStorm to work on it. The 2017.1 version is downright unusable for this on all 14 dev machines (Mac and Windows alike). We were REALLY looking forward to the new features in 2017.1 but now a bunch of the team is considering alternatives because it's just that bad.

For us the is a total deal breaker - if it's not fixed soon we are going to have to abandon WebStorm altogether.


 There are dozens of possible reasons for slowdown. There is no chance to see what's wrong unless you provide snapshots (if it runs slow) or thread dumps (if it stops responding completely).

so, instead of spamming forums with "+1", please create support tickets, providing the informtion that can be used to track down and solve the problem



I have installed IntelliJ 2017.1.2 and faced the same problem. IDE hangs when I try to edit some TypeScript files in an Angular 2+ project. I've tried various solutions, incl. this one: https://youtrack.jetbrains.com/issue/IDEA-170207 No luck. 2016.x was ok. Very disappointing.

My project is here: https://github.com/ova2/angular-development-with-primeng Just open it and you will see.

BTW, there are many posts with the same problem, just do a google search "IntelliJ 2017.1 hangs". Something went wrong with 2017.1.


I can also confirm that on 2017.1.2 I still experience this problem on my MBP.

It can be triggered by an action as simple as add/delete a single character to/from the code; the result: IDE becomes unresponsive for 5-15 seconds. During the stall I see (in activity monitor) the WebStorm process cpu goes over 100%. Any (inadvertent) typing I did in between is fast-forwarded thru once the idea becomes responsive again, resulting in typos and misplaced characters. This to my annoyance adds another unresponsiveness-cycle of 5-15 seconds.

I'm experiencing this problem since upgrading to 2017.1 (March 20th) which means it's over six weeks now. Each time I bump into it (sometimes, every minute or so) I can't avoid the frustration;  it just feels that my time isn't valued enough for Jetbrains to get this issue fixed.

Jetbrains staff would do well to take this issue more seriously, bump up the priority and post updates here. tmho this has reached the point of hindering the product. It's silly and unfortunate that users need to comment over and over again. 

Lastly, @Elena: I would love to take snapshots, upload logs or whatnot. But I couldn't find out a straight-forward way to do that. If you want us developers to upload the logs, please provide a clear howto page which can be completed fast. It makes no sense for developers to spend half a day on figuring out how to upload the IDE screenshot. It should be a 2 minutes max process, or we wouldn't bother


Yes, exactly, it happens since upgrading to 2017.1. IDE becomes unresponsive for 5-15 seconds. I just tried the same project in 2016.x, no problems at all. That means, there is a bad regression in 2017.1 which makes development with TypeScript and Angular impossible. I've created an issue in the bug tracker with my threadDump: https://youtrack.jetbrains.com/issue/IDEA-172175


I am also using Meteor, and my beloved WebStorm is no longer functional since I upgraded. Everything is slow. I have found: 




The latter notes:
A dump should be taken exactly at the moment when IDE doesn't respond and will record the thread stack. Recording several thread dumps with 1-2 seconds interval can be also very useful for the problem analysis.

I'm not sure how you do something "exactly at the moment..."

I really disagree with calling customers "spammers" who are plus one-ing  issues that we have in common. I don't think that point of view recognizes just how much of a shock it is to be going along using an IDE for years, and suddenly finding yourself unable to function... or with huge slowdowns... and then to face pages of documentation even on how to report the issue. Honestly, if a whole bunch of people were plus-one-ing something, it might be a helpful clue on where the issues are. I'd rather that JetBrains valued +1, especially since the function is here. (also, when I clicked the 1, I actually thought I'd be adding a comment at first.)

For the next 24 hours I'm going to work on my project (I'll be using a different IDE), and then I'll resurface to try to focus on all that documentation above for how to report an issue. I do want to come back to WebStorm. I like it. My hands know the keyboard shortcuts. And I do hope to be able to return to full function. 

For now, can you clarify "exactly at the moment?"  When a slowdown occurs, move to a terminal? I guess i need to close meteor server, or duplicate the tab to be able to do that. In any case, it won't be "exactly at the moment..."


>For now, can you clarify "exactly at the moment?"  When a slowdown occurs, move to a terminal?

The quotation is from https://intellij-support.jetbrains.com/hc/en-us/articles/206544899 that provides instructions on getting thread dumps. Thread dumps are only useful when the program stops responding, it's not about slowdown. If you see that the IDE hangs and stops responding to events, you have enough time to move to a terminal, attach a jstack, etc. And, if it's a slowdown, not freezing (i.e. when you see some delays with getting completion, etc.), dumps are mostly useless, you need taking snapshots using instructions from https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems.


This has been happening quite frequently for me now. 

Thread Dump here: https://www.dropbox.com/s/8dawirr2ard0o9p/threadDump-20170526-095157.txt?dl=0

And here's my mac os crash report:  https://www.dropbox.com/s/jwx6hyhyl11hnac/macos-webstorm-report.txt?dl=0

Webstorm hangs about every 15-30 minutes, requiring a force-quit. I'd had a much more severe version of this problem earlier when I initially switched to Mac OS Sierra due to sudo commands taking a long time to execute. When that was fixed, the hanging went from every 5 minutes to every 15-30 minutes. Please let me know progress on fixing this, this absolutely kills my productivity.



please can you provide your logs directory (~/Library/Logs/WebStorm2017.1) content (all idea.log.* files and thread dumps)?


Sure thing Elena, the below link is a zip of my entire WebStorm2017.1 directory:



neither logs nor the auto-generated dumps show any issues.. Dumps only show very minor delays mostly related to indexing, idea.log shows no issues at all, except for 1 index rebuilding. Can you clarify what you mean by hanging? Does it stop responding completely, so that you have to kill it? Can you try excluding all folders dynamically generated by build tools from your project (Mark directory as/Excluded) and check if the problem persists?


Hanging basically starts when I get the cursor as a pinwheel and everything is unresponsive. I then do a force quit (command + option + esc) and Webstorm is listed as unresponsive. I can't see a pattern around any type of action I'm taking when this happens, meaning it can happen when I'm typing, clicking around etc. Oftentimes when I command + tab to Webstorm if it's been in the background for a while (not my "active" app) it'll be in a hung state. I'll see what folders I can exclude to see if this helps. I work on 2 react based projects, one medium sized, another one very small and the problem seems to happen at the same rate with these two projects.


Hi @Elena, I did configure my project to exclude the build directory. This unfortunately doesn't seem to help, it is still crashing 10-15 times a day. I should mention too I'm on a fairly fresh install of Sierra, a brand new MacBookPro, so I'm at a loss as to what other software may be impacting this. I should mentioning too I also run the latest Intellij with no problems at all.


>Oftentimes when I command + tab to Webstorm if it's been in the background for a while (not my "active" app) it'll be in a hung state.

well... I can only say that your logs don't show up any similar issues. Try disabling 'Synchronize files on frame activation' (Preferences | Appearance & Behavior| System settings) - does it make things any better?

CPU snapshots taken when it runs slow would be helpful...


Hi Elena, I actually was having more stability when I followed your advice to disable `Synchronize files on frame activation`. But I just now made the fatal mistake of upgrading my OS to 10.12.5. Webstorm now will not stay open for more than a few minutes without hanging and thus requiring a force-quit. The fun part too is it now fails to save my latest work. I have not seen any thread dumps generate and I'm not able to generate them on my own. The below is the link to my crash report. I can't capture a CPU snapshot since Webstorm is completely unresponsive for me to stop the profiler to collect the snapshot. Is there another way to capture this? I have to switch IDEs now, I'd really like a solution to this.



Do you have any java_error_in_webstorm_*.log files created in your $HOME directory? Of course, I need the ones generated recently, since upgrading your MAC


Hi Elena, so no java_error_in_webstorm is generated when this hangs. Below is a link to my idea.log file, this seems to be the only thing in my webstorm folder. I'd cleared the previous threaddumps and other files earlier and for all the hangs and force-quits I've done, no files seem to get generated.

Is there any debug logging you'd like me to turn on? Has anyone at JetBrains had luck in reproducing this? 



Nothing in the log unfortunately:(

Can you try getting dumps with JStack or by pressing Ctrl+\ in the Terminal window?


This is what I get when I attempt a jstack dump:

$ jstack -l 39426 > dump.txt
39426: Unable to open socket file: target process not responding or HotSpot VM not loaded
The -F option can be used when the target process is not responding

I removed WebStorm from my machine and re-installed. It now hangs before even getting to completely loading the splash screen. Any other ideas on how to get more insight into what's going on? 


Please delete your WebStorm caches and preferences

rm -rf “~/Library/Preferences/WebStorm2017.1″
rm -rf “~/Library/Caches/WebStorm2017.1″
rm -rf “~/Library/Application Support/WebStorm2017.1″
rm -rf “~/Library/Logs/WebStorm2017.1″

does the problem persist?

if yes, try getting dumps in console - start webstorm from terminal, then use  Ctrl+\ to generate dumps


Hi Elena, I followed the instructions above to uninstall Webstorm and delete the above folders. I've been running Webstorm from the terminal, and so far I've not had any hanging :)

I'll keep running it like this and get a dump if it hangs again.



Great, thanks for update!


Hi Elena, here's the latest update. I had been running Webstorm via the terminal for close to two days with no hanging whatsoever. I then restart Webstorm using the conventional non-terminal approach, Webstorm proceeds to hang again! So it seems Webstorm is fine and stable when run over terminal.


So I tried running it from the terminal and it *does* seem to be way better. Its using less memory than it was (usually around 900MB instead of 1.6GB) and even when it does balloon up to 50% CPU and 1.9GB memory, its temporary and doesn't hang the UI. I've only been using it this way for about 8 hours, but its SOOO much better. I've only seen the UI hang briefly maybe twice today so far.

Why would running it from the terminal make this big a difference? Looking at the shortcut I normally run it from, its the same binary ("C:\Program Files\JetBrains\WebStorm 2017.1.3\bin\webstorm64.exe") and it doesn't have any command line options (just like i ran it with no command line options from the terminal). 


Please sign in to leave a comment.