When using multiple monitors, popup windows and context menus are not positioned correctly.

Answered

I am using Fedora 25 with GNOME version 3.22.2, and when i open a popup, like say i try to find in the project, those windows will always appear on my second monitor (I expect them to appear on the monitor which has intellij opened).

Also, my second monitor and laptop monitor are different sizes, and when i open a context menu on my laptops monitor, it seems it sizes the context menu as if it was made to fit my second monitor. Meaning the top of the context menu is completely cut off.

It seems as if, for whatever reason, IntelliJ thinks the second monitor is my active monitor even though the application is in my first monitor.

Anyone else have these problems?

14 comments
Comment actions Permalink

https://youtrack.jetbrains.com/issue/IDEA-157583  sounds awfully like a problem I am having.  I am running:

IntelliJ IDEA 2017.2.5
Build #IU-172.4343.14, built on September 25, 2017
Licensed to McKay Brothers / Bill Evans
Subscription is active until January 12, 2018
JRE: 1.8.0_152-release-915-b12 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

This is a very annoying issue with the only workaround being to confine Intellij to a single screen.

How can this be escalated and is there an ETA for when this will be fixed?

 

0
Comment actions Permalink

Just a note to say that I experienced the same problem and that the workaround that worked for me is described in https://youtrack.jetbrains.com/issue/JRE-709 ... (switching the IDE's boot jdk) fixed the issue for me.

Specifically I changed the JDK used for bootup of the IDE (Refer https://www.jetbrains.com/help/idea/switching-boot-jdk.html) ... and I changed it from the bundled JDK (1.8.0_152) to a locally installed JDK version of 1.8.0_161-b12.  After a restart of the IDE the menu's are now correctly located (not on my second monitor).

IDE: Help -> Find Action -> Enter "switch boot jdk"  -> select a locally installed newer JDK like 1.8.0_161 -> restart the IDE

 

 

 

 

8
Comment actions Permalink

@Rob Bygrave:  Your solution is work for the popup in the middle of the interface (Ctrl+Tab now work well). but for context menu is popup at left monitor still. 

0
Comment actions Permalink

For anyone arriving here (as I did) with similar issues related to dialogs on a multi-monitor setup on a Mac, the following fix may make you feel equally as stupid as I did, but should help:

Ensure that WebStorm/IntelliJ/Etc is not assigned to a specific space

  1. Click and hold the icon in your dock
  2. Hover over "Options"
  3. Under "Assign To", select "None"
  4. Facepalm
3
Comment actions Permalink

@Rob Bygrave : switching boot JDK solved window and popup/context menu placement.

Using Linux Mint 19 with 3 monitors with the same resolution but different size/dpi 

0
Comment actions Permalink

Thanks for Rob Bygrave, but is there any solution for the second monitor? This bug is really annoying, I use my second monitor very often.

0
Comment actions Permalink

The same issue on Ubuntu 16.04, I tried all JDKs in my machine. The popups do not work on my second monitor.

0
Comment actions Permalink

Thanks, Rob Bygrave!

I just encountered this issue on a dual monitor setup with Ubuntu Desktop 18.0.4 using the stock Gnome desktop with added tweaks. My laptop monitor is set as display #1 at 1600x900 resolution, and I have an external 24-in as display #2 at 1920x1200 resolution. The monitors are set so the bottom edges align -- meaning the top of display #2 is 600 pixels above display #1. When running the most recent version of PhpStorm on display #2, the dropdown menus (e.g., File, Edit, View) would open with the menu block partially overlapping to the left. If the menu was long enough, a portion would appear on display #1; otherwise the remainder was lost in the non-desktop void. 

The default Boot JDK bundled with PhpStorm appears as '1.8.0_152-b28' in the Switch IDE Boot JDK. I installed Java 1.11.0 OpenJDK [10.0.2+13] and it resolved the issue. Further, since the install updated libraries that the version installed by PhpStorm uses, I was able to switch back to the default Boot JDK and one (or more) of the library updates appears to be what resolved the issue.

---Rob 

1
Comment actions Permalink

I had the same problem. I have a laptop with Ubuntu 18.04 and an external monitor. context menu window position fine on laptop monitor but not on external monitor. I was on java 8.0 bundled with CLion. Then I installed Java 11 on Ubuntu and the problem was resolved. Thanks @Robert Emenecker.

0
Comment actions Permalink

I encountered the same issue with the latest PyCharm 2019.3-EAP and same monitor setup as Robert Emenecker. I tried to switch to Ubuntu JDK using the Choose Runtime plugin but it did not help. As I have no more time to experiment I reverted to 2019.2.2 and it works much better.

1
Comment actions Permalink

I have a similar issue and changing the runtime did not help. I have a laptop and an external screen in upright mode. I use this external screen for coding. What I have found is that the dropdowns work fine if they are in the area that corresponds to the laptop's area, but otherwise they are constrained vertically, i.e. on the second monitor every dropdown that should appear in the upper half actually appears in this lower area.

0
Comment actions Permalink

Please check the official JetBrains comment on that: https://youtrack.jetbrains.com/issue/IDEA-157583#focus=streamItem-27-3835904.0-0 .

0

Please sign in to leave a comment.