How to prevent Find from coming up in a floating window in WebStorm 2017

Starting in the latest WebStorm, when I do a Find operation, it shows up in a floating window (see below).

I want it to be docked by default, like it was before this upgrade. How do I do that?

 

9 comments
Comment actions Permalink

Hi there,

What do you mean by "docked by default"?

Are you talking about search results? If so --  the preview was available before as well -- but it was separate tab -- now it's part of the actual window. Just click on "Open in Find Window" to see results in separate tool window.

0
Comment actions Permalink

By 'docked by default' I mean that, yesterday, my results would not be in a floating window, but with the update, they are now. Clicking on "Open in Find Window" is annoying for me, since I don't want to have to use my mouse every time I do a search. 

One of the main problems I have with this new floating search is that after I've selected and navigated to a result, the search results go away

0
Comment actions Permalink

You can switch to the old dialog by deselecting ide.find.as.popup in Registry: Help | Find action, type Registry to locate it, find the option there and deselect the checkbox

4
Comment actions Permalink

Thank you for the solution to this. 

My issue isn't with the new UI, which is nice; it's having to press Ctrl+Enter now to show the search results in a find tab. Since using Webstorm (with Visual Studio keybindings) for the past 3 years, it's been

Ctrl+Shift+F --> Type Search --> Press Enter --> Results in the results tab.

I've become so accustomed to typing that combination so quickly (both in Webstorm and Visual Studio Code), that I'm always forgetting the Ctrl+Enter at the end now. I'm thus now always having to type my search in a couple of times; once where I just press Enter and something useless happens, and then again with Ctrl+Enter where I get the required functionality.

3
Comment actions Permalink

All I can say is +1, yes I also want to have an option where my "Find in path ... " always shows up in a Find Window instead of always needing to select the "Open in Find Window" button.  I see that I can type Ctrl-Enter but why do I need to do that every time. 

4
Comment actions Permalink

I love the floating window - I just don't want it to disappear when I go to one of the search results by double clicking.

Surely a 'stay visible until I close' option would be simple enough.

It's really poor compared to most of the way the IDE is thought out and works.

3
Comment actions Permalink

Is deselecting `ide.find.as.popup` in Registry still possible with PHP Storm 2020.1.1 ? I cannot see that attribute in the registry.

1
Comment actions Permalink

No. This option has been removed in 2019.2. Old style Find in Path dialog is deprecated due to many issues with it, there is no way to re-enable it

-1

Please sign in to leave a comment.