How to set the debug option to use Rspec on the current file?

I'm using RubyMine 2017.1 on OS X and am working on a Rails app. I would like to set the default debug test option in the right click menu (or the keyboard shortcut: Ctrl + Shift + D) to be RSpec instead of what it is now.

Currently, it uses another testing tool but it does attempt to run the test that's under the cursor.

I normally use the keyboard shortcut Ctrl+Shift+D to run the test.

I'm sure there's a configuration that I'm missing, but I'd appreciate any help!

4 comments
Comment actions Permalink

Yes I would like to know how to do this as well.  All of a sudden Ctrl + Shift + R defaults to Minitest instead of Rspec and I can't seem to find out how to disable that in the runner options.

0
Comment actions Permalink

I'm wondering if this was a result from the new update. What version are you using @Navid?

0
Comment actions Permalink

I believe it is, I am on 2017.1

 

I think it is resolved once 2017.1.1 comes out....

https://confluence.jetbrains.com/display/RUBYDEV/RubyMine+2017.1

https://youtrack.jetbrains.com/issue/RUBY-19106

0
Comment actions Permalink

Me too!

Auto-selection of rspec for the testing framework definitely "broke" as soon as I upgraded to 2017.1 (RM-171.3780.96). It now tries to run minitest. This same muscle memory keyboard shortcut has always run rpsec for the last few years I've been working in Rails apps using rspec.

I haven't found any information about how Rubymine chooses which configuration to run by default.

Heh, looks like this is about to get fixed in 2017.1.1 as this bug is mentioned in the release notes as fixed: https://youtrack.jetbrains.com/issue/RUBY-19106

 

0

Please sign in to leave a comment.