Large increase in stripe marks [WebStorm 2017.1]

Since upgrading to WebStorm 2017.1 I am seeing a massive increase of right sidebar stripe marks (yellow using the Dracula theme), example attached.

I went through and turned off every single yellow stripe mark but was unable to determine the mapping. I also disabled syntax checking and still the marks persisted. The only thing I can come up with is that 1 yellow stripe marks is one line of code (in the example image there is 1 stripe mark for everything besides the closing brace of the function). A 1:1 stripe to line is obviously not very useful and can't be in the intended implementation.

Anyone else seeing and/or any idea what would disable?

 



 

8 comments
Comment actions Permalink

can't recreate

 

does the issue only occur in scratch files? Please hover over the stripe mark - do you have any tooltips displayed?

0
Comment actions Permalink

Hi,

No it is not only scratch files but it only happens with certain schemes, default is fine but Dracula is not.

I created a fresh project and used unmodified Dracula, still seeing same result. Screen shot of hover results attached but it seems to confirm what I mentioned earlier, basically a stripe for ever line of code. Can you try with Dracula? I am on OS X.

Thanks!
Brent

 

 Hover:

 

Default scheme:


 

 

0
Comment actions Permalink

hmm.. no luck with darcula

please can you export your settings (File | Export settings) and provide them along with your idea.log?

0
Comment actions Permalink

Weird -- Here are the requested files

Thanks for the help.

Brent

0
Comment actions Permalink

still the same - installed all your custom plugins and imported settings, to no avail. is the issue specific to certain project?

0
Comment actions Permalink

No I created a fresh project for the screen shots I sent.

I guess it must be something on my end. I just tried with RubyMine (which uses the same settings via the settings repo) and it does not show the markers on js files. I don't know, maybe I will should blow out my entire WebStorm and start from scratch. Thanks for trying though!

 

 

0
Comment actions Permalink

I am embarrassed to say this but I just tried restarting my computer and it now works fine.

0
Comment actions Permalink

I see, thanks for update:)

0

Please sign in to leave a comment.