Perforce Plugin only works with some, but not all files, in project

Hello,

I am trying to get AppCode's Perforce plugin to be able to open files for editing, from within AppCode.  I've noticed that only some of my project's source-code files can be 'p4 open'ed from within AppCode, namely, those that are in directories that contain an Xcode project, or subdirectories of said directories (that contain an .xcodeproj).  Files that are not in those directories, such as those one directory up from an Xcode project, cannot be 'p4 open'ed from within AppCode.

The app I am working with has a directory structure that places its .xcodeproj files inside "iPhone" subdirectories, but has much of its source code (mainly Lua scripts and cross-platform C++ files) inside 'Source' directories, which are not subdirectories of the iPhone directories.  For example, here is a sample, directory structure:

 

ProjectRoot/

    Source/

        SomeFile.cpp

        SomeScript.lua

    iPhone/

        MyApp.xcodeproj

        Info.plist

        Images/

            Default.jpg

 

In the above example, I can successfully 'p4 open' the Info.plist and Default.jpg files, but not anything inside Source/.

 

Re-arranging the project's directory structure is, unfortunately, not an available option.

 

Is there a way to get AppCode to 'p4 open' the files inside that Source/ directory?

 

To note, I am using:

  • AppCode 2017.1
  • Perforce Integration plugin v2.0
  • macOS 10.12.4
  • p4d 2016.2
  • p4 command-line client 2016.2

 

Cheers,

-- David Ludwig

6 comments
Avatar
Tatiana Shabaeva
Comment actions Permalink
Official comment

Hi David.

Could you please share screenshots of "Preferences | Version Control" and "Preferences | Version Control | Perforce" (with sensitive data stripped, if there is any)?

Comment actions Permalink

Hi Tatiana,

I did not see a preference pane in that exact location, but did find one under the AppCode menu --> Preferences... --> Version Control --> Perforce.  Attached is a screenshot of that dialog.  If you'd like me to grab a screenshot of a different UI, let me know.

Cheers!

-- David L.

0
Avatar
Tatiana Shabaeva
Comment actions Permalink

David, 

Apologies for confusion, I've actually needed 2 screenshots: the one you attached and another one, from "Preferences | Version Control" (I've corrected my previous post to include quotes where needed).

0
Comment actions Permalink

Hello Tatiana,

Attached is a screenshot of the other dialog, "Preferences | Version Control".

If you need any other(s), let me know.

Cheers!

-- David L.

 

0
Avatar
Tatiana Shabaeva
Comment actions Permalink

David,

Please try to alter VCS mapping at "Preferences | Version Control": instead of <Project>, select <Directory> and specify path to project root folder. Let us know if it helps.


 

0
Comment actions Permalink

That works, however, I now have an absolute path name in my project.

Is there a way to specify a path that is relative to either the AppCode or Xcode project?  I tried "../..", but it did not work, and instead appeared to point to something inside AppCode's own .app bundle.

0

Please sign in to leave a comment.