9 comments
Comment actions Permalink

Please can you provide a screenshot of Preferences | Languages & Frameworks | JavaScript | Code Quality Tools | ESLint page and your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)?

Note: please do not paste the log content here, just upload a file to some file server and provide a link

0
Comment actions Permalink

Thanks:)

From the log I can see that ESLiont service receives mailformed json it can't parse:

Cannot parse answer for protocol: com.intellij.lang.javascript.linter.eslint.service.protocol.ESLintLanguageServiceProtocol, text:
 {"request_seq":2,"command":"GetErrors","body":[{"filePath":"E:\\work\\eluyun\\static\\js\\app\\src\\ordersManage\\components\\OrderEditor\\RoomEditor.vue","messages":[{"ruleId":"semi","severity":2,"me
 ................................(truncated)
com.google.gson.JsonSyntaxException: com.google.gson.stream.MalformedJsonException: Unterminated object at line 1 column 2616 path $.body[0].messages[10].source

 

Is the issue specific to certain files being linted (.vue files, for example)? Try opening other files - does the problem persist?

Also, please can you provide your package.json and .eslintrc?

0
Comment actions Permalink

Yes, it only happened to .vue files but not every .vue file.https://drive.google.com/open?id=0B5UWnW55k4YARjRFcU4xZXdEOG8 

0
Comment actions Permalink

Thanks! ESLint works for me when using your configuration. I tried different .vue files - to no avail. Please can you provide files that show up the issue? `ordersManage/components/OrderEditor/RoomEditor.vue`, for example?

0
Comment actions Permalink

Thanks! Still no luck unfortunately:(

Please can you try enabling ESLint debug logging: in Help - Debug Log Settings..., add the following text to set the log category to TRACE level:

#com.intellij.lang.javascript.compiler.JSLanguageExternalCompilerImpl:trace


then recreate the issue and provide the resultant idea.log

0
Comment actions Permalink

I also encountered this problem in IDEA 2017.1 by using Setting>Languages & Framworks>JavaScript>Code Quality Tools>ESLint .  And I resolved it by using Setting >Other Settings > ESLint. Or you can use IDEA 2016 too.

0
Comment actions Permalink

The problem is likely related to encoding. Please see https://youtrack.jetbrains.com/issue/WEB-26393#comment=27-2120808 for possible workaround

0

Please sign in to leave a comment.