Flashing screen

Hello! 

Every now and then, WebStorm's UI starts to blink. It's quite hard to articulate the problem, so I have attached a gif that shows what I mean. I tried to search this community for similar reports, but I didn't find any. 

I'd be happy to provide any additional information. 

Version info

WebStorm 2017.1.1
Build #WS-171.4073.40, built on April 11, 2017
JRE: 1.8.0_112-release-736-b16 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Mac OS X 10.12.4

 

24 comments
Comment actions Permalink

This also happens on latest PhpStorm 2017.3.3 and earlier.. I've actually thought I have problems with my laptop screen.. Or my eyes.. but seems like I'm not the only one.... 

0
Comment actions Permalink

yes this is supremely annoying -- everyone in our office has this happen with PHPstorm

0
Comment actions Permalink

I found this happened when I had a monitor refresh rate less than 60hz.  I had an ultrawide 34' set to 50hz under hdmi.. but when i connected it to displayport, it was set to 60hz and the issue no longer exists. 

edit: the link Elena attached also confirms my assumptions.

0
Comment actions Permalink

Same here. Usually happens on wake up after sleeping mode. Stops blinking after 1 minute or so.

0
Comment actions Permalink

Happened for me using a 4k tv as a monitor with all the appropriate 60hz settings and cords.  Changing the screen size scale in display to lower res and then back to higher made it stop.

0
Comment actions Permalink

I had this start happening after several years of using PHPStorm without issue on a Mid-2014 MacBook Pro

This is now a recurring issue that started occurring immediately after changing my primary monitor (of a multi-display setup) from DisplayPort(Adapter)-to-VGA to direct HDMI. Issue resolves itself after either restarting PHPStorm, or temporarily changing display resolution.

PhpStorm 2018.1.4
Build #PS-181.5087.24, built on May 18, 2018
JRE: 1.8.0_152-release-1136-b39 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.12.6

0
Comment actions Permalink

Happens to me too - exactly as Mikhail Lobanov described

 

IntelliJ IDEA 2018.3.1 (Ultimate Edition)
Build #IU-183.4588.61, built on December 4, 2018
JRE: 1.8.0_152-release-1343-b16 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

0
Comment actions Permalink

Same here with PHPStorm and my new Dell U2419HC (USB-C) monitors attached to my Macbook Pro.

My previous monitor (Dell U2419H) did not have this problem.

0
Comment actions Permalink

I saw the same in Rubymine.  I notice that the flicker matched the timing of the flashing of the cursor in editor and terminal windows.  I found the caret blinking option and disable (Preferences | Editor | General | Appearance | Caret Blink).  Initially this made the situation worse since the flicker became constant like a spastic fluorescent bulb.  I then closed the IDE and reopened and no more flicker at all.

 

0
Comment actions Permalink

Same here with DELL U2417H, macOS Mojave in PHPStorm 2018.3.3 and in GoLand 2018.3.3

0
Comment actions Permalink

I had two projects open, one did it while the other was not doing it. Closed it / reopened it worked.

0
Comment actions Permalink

I fix it by resize the windows and maximize again. dunno why but that's work haha

2
Comment actions Permalink

I've just started having this behavior after upgrading to Pycharm 2019.1

Edit: In my case the flicker went away when I stopped using a font that I had custom installed.  When I change my font to 'Fira Code Retina', the problem goes away.  I'm running a 2018 15' MBP, Radeon Pro 555, macOS Mojave.  

To recap, this was only happening when:

1) Using a custom font

2) And running on an external monitor

 

 

0
Comment actions Permalink

I found it happened when I moved the cursor left or right while crossing the vertical indentation guides (grey lines). The grey line would highlight and all the other text would get darker.

I disabled indentation guides and the flicker went away too.

PyCharm 2019.1 (Community Edition)
Build #PC-191.6183.50, built on March 19, 2019
JRE: 11.0.2+9-b159.30 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

Edit: nevermind, that was temporary. Somehow the flickering still appears when I click around to place the cursor in different spots. Frustrating!

1
Comment actions Permalink

This just started after upgrading to PyCharm 2019.1.

It happens when I am clicking around between lines, sometimes large blocks of the code get much dimmer, then brighter. It's a really weird effect, and distracting.

Running MacOS 10.13.6 on a MacBook Pro (15-inch, 2016).

I blew away my Preferences folder and set all my preferences up from scratch to see if that may be the culprit, and it seems like I don't notice the issue as much when using the Light theme, only when changing to Darcula.

0
Comment actions Permalink

@Mmarziani it must be https://youtrack.jetbrains.com/issue/JBR-1348; please try the workaround from the ticket - does it help?
The fix will be released with 1544 JBR build. It will be available at https://bintray.com/jetbrains/intellij-jbr/jbrsdk8-osx-x64 soon and will be bundled with the next update.

1
Comment actions Permalink

Hi @Elena

Running `defaults write -g CGFontRenderingFontSmoothingDisabled -bool Yes` in the terminal stopped the lightening and darkening when I click around. Now it's always darker, but at least not distracting.

Thank you for helping me with this workaround and informing me of a fix in the works! Have a good day :)

0
Comment actions Permalink

This issue appeared in  Pycharm 2020.1; while using a high def monitor. 

So, for me

Antialiasing was set to "subpixel" as shown in figure.

I changed to "greyscale"

 

The flickering disappeared!
There is another option to completely disable antialiasing, but the font appearance was bad.
If I switch to subpixel the flickering comes back.
So, greyscale seems like a happy medium choice.

 

0
Comment actions Permalink

Will give it a try…

Still, the bug is ridiculous!

0
Comment actions Permalink

It's flickering, with "grayscale" too.

JetBrains, can you please take a look into the issue, and provide the official solution? Your software looks like shit from the 3rd world.

0
Comment actions Permalink

I don't get it why restarting the IDE would solve this annoying flicking issue and it comes back every once in a while when I have the IDE idle in background for long time.

0
Comment actions Permalink

Apple repaired my working MacBook in June, and that forced me to reinstall everything, from scratch. And it helped! Annoying flickering has gone since that, and the result is very consistent since then.

I blame old JRE installed in my previous system, but it'd be really helpful if such a bug would be known (and treated) by JetBrains people.

0
Comment actions Permalink

For me, the problem was solved after I opened my project locally rather than from a network drive. Good luck to you all.

0

Please sign in to leave a comment.